Prebootstrapper error message

installation

#1

I was having an issue with 2016 Pro not converting Layout files to PDF’s on my Windows 7 pro desktop. The PDF converter works fine on my laptop. So I decided to remove SU 2016 and reinstall the program. Now, I get a “prebootstrapper” error message, and will not run the setup.exe file. HELP!


#2

run setup by “Right Click > Run as Admin”.


#3

No go. Next idea?


#4

download and install the MS runtime libraries required by SU 2016 separately:

  - Microsoft Visual C++ Redist. 2015
  - Microsoft Universal C Runtime Update f. Win 7/8.x

run setups by “right-click > Run as Admin”.


#5

Ah, I have not tried that… I’ll report back.


#6

No go.


#7

try

  - Microsoft .NET Framework v4.5.2+

too.


#8

Have you installed the C++ libs using ‘Run as administrator’ ?
Have you then installed SketchUp from the installer exe using ‘Run as administrator’ ?
Check that the SketchUp and Layout exe program files themselves are not set to run in Compatibility mode or to Always Run as Admin…


#9

Yes, no go.


#10

How would I check the SU and LO exe program files?


#11

if you didn’t know that you probably haven’t changed anything there… “right-click on execuatbale or program link > Properties > Compatibility”.


#12

Alright, I did that, and changed all to run as “Windows 7 compatible”… still no success.


#13

don’t change anything as already elaborated by TIG.


#14
  • open “Setup###.exe” with a ZIP application or rename from “Setup###.exe” to “Setup###.exe.zip” and double-click
  • copy complete content of setup package to a local drive by bewaring the directory structure
  • launch “Setup.EXE” by “RClick > run as Admin”
  • if this fails too: launch “Setup###.MSI” by “RClick > run as Admin”

#15

What in the heck… I downloaded the MSI silent installer version from the SU help center, and it loaded right up. What is the difference between the two versions?


#16

the MSI inside the setup package is the same as the MSI version from the SU Help Center. The setup routine additionally contains/downloads and installs the prerequisites listed above which are required for running SU.


#17

I was trying to install the “(64-bit) Windows 10, 8, 7” version all along, not the “Silent Installer (MSI) 64-bit” version. Was this the issue?


#18

the full setup contains/downloads and installs the prerequisites which are required for running SU, installing a pure SU by using the MSI does lead to a working SU only if the prerequisites are already on the system.

the issue arises if the installation of the prerequisites hangs/fails because of e.g. missing user rights or conflicts with already installed runtime libs or…


Layout (SU Pro 2016) will not convert files to PDF
#19

Well whatever it was, SU is up and running on my machine. Thank you, thank you, thank you for your help!


Layout 2018 export error - there was a problem exporting to this file
Layout 2018 upgrade install and export issues
#20

A post was split to a new topic: Layout will not export PDF