Placing rectangle/plane light on angled surface


#1

Hello everyone,

I am using Mac OS 10.12, Sketchup 2017, and Vray 3.4.

I am attempting to place a rectangle/plane light source on an angled surface (onto a light component that I’ve added). I am struggling sooooo much to place the light source at the correct angle, and I feel like there should be an easier way. The rotation tool is difficult to control, and even when rotating from the midpoint, it seems to skew the angle of the rectangle. What am I doing wrong?

Thank you in advance!

Haley


#2


#3

What settings do you have in Window->Model Info-> Units ?
Is angle snapping enabled?


#4

Place an instance of the light component away from everything else.
Select it > Context-menu > Change Axes
Pick a point on the 'frame where you’d like it to overlay the surface it’s going to be glued to.
Make X red the long direction, and Y green the short dim, but note this step carefully - set the Z blue axis to be pointing away from the surface onto which it will be placed.
Confirm and delete the temporary instance.
Also delete the current instance as it needs a new version adding…

Now go into the Components Browser > Model pane, and select the light component, Edit it and in the Alignment options choose Glue to: “All” and tick the ‘Cut Opening’ checkbox.
Place an instance of it onto any face - including your sloping soffit - and it should now glue to the face, I chose to ‘cut-opening’ because it looks like it’s a ‘box’ recessed into the face it’s placed on to.

If for some reason it doesn’t seem to glue as expected, first check that its axes are correct if not correct them and place a new instance; next check that the face you are gluing to is not ‘reversed’ - View > Monochrome to see this - if your Style has a distinctive back-face color - default is usually a blue-gray - you should not see it - because a gluing object always matches its face’s ‘normal’ an incorrectly oriented face will get the instance ‘back-to-front’. To fix a backwards face, Select it and use the Context-Menu to ‘Reverse’ it…


#5

​Hi,

Thank you so much for your response. This did not work for me, and I think
I know why. The wall that the lighting fixtures are on, is not on the red
or green axis. The building has one angled wall, and has proven really
difficult to align things. ​Also, when I create the plane light and attempt
to follow your steps, it is not automatically being added to the component
list, like the other lights in my model, and has the option for making it a
component de-selected. I’m not really sure how to proceed. Like I said, I’m
really new to Sketchup, so I’ll continue to struggle my way through…

Thanks again,

Haley


#6

If you right click on the lamp , you can save it as a small sketchup file ( provided it is a component, select the lamp, right click and choose ‘Save as’ )
Upload the file her on the forum (7th icon from left) , so we can inspect the component.


#7

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.