Pause in latest version of Sketchup for Mac

When is this going to get fixed? It pauses for 1 second after EVERY command in every model I have. I thought it was a laptop thing and M1 but its doing it on the latest version on my iMac too.

Please fix this right away!!!

1 Like

Any special input devices, like a 3D Connexion navigator?

Your post suggests that every Mac user must be suffering the same way. Well, I’m not. But I don’t have the latest iMac and I haven’t yet upgraded to the latest OSX Maybe there’s a clue there somewhere?

Oh, and I have been using a SpaceMouse without problem for some time.

To add, SketchUp is not yet supported on MacOS 12 or Windows 11.

It is probably the “haven’t yet upgraded to the latest OSX” part. I have the same problem on my M1 MacBook Pro and 2017 iMac with Intel. They are both running the latest OS since that is usually what Mac people do. I guess I have to start being careful when upgrading.

1 Like

I have no such lag on my Mac. I’m always at least one OS behind the cutting edge current offering, for fear of breaking some part of my workflow that is not yet updated for the latest OS. I’m currently running Big Sur 11.6 and SketchUp/Layout without any problems.

Does it do this with an empty file? Is it possible your file has simply gotten very big?

For what it’s worth …

I have a week-old macBook Pro with an M1 Pro chip. On it I’m running:

Monterey version 12.1 beta
Sketchup Pro subscription 21.1.331
3DxWare 10.7.0(3295) - 3DxMacCore version 1.2.0(100)

Absolutely no problems with pausing and the 3D mouse works perfectly.

On the same machine I’m also running:

Parallels version 17.1.1
Windows 11 Pro version 21H2
3DxWare version 10.8.3
Sketchup Classic version 21.1.332

Absolutely no problems with pausing and the 3D mouse works perfectly.

Perhaps I’m just lucky.

Try a 50 is meg file or download a decent size file from the warehouse. Try Coffee shop. If you can get that to work just fine and you can draw without a pause after every step of say a line… tell me how to get your luck. I have a brand new MacBook Pro too with M1. 16 gigs. Used to work perfect prior to Monterey. Lots of others here having the problem too so they may need that luck too. My iMac Pro was having a problem with profiles and a lag. Once I disabled it that solved that issues. Still trying to figure out the laptop though. Luckily I dont use it for Sketchup much.

Just tried it just now and didn’t seem to have any problems.

The model I chose was Channel Glass Coffee Shop
3,419,389 edges
1,300,879 faces
145,256 component instances
39 MB

Zoomed right in and added some new faces without experiencing hesitation. There’s quite a lot of vegetation in this model which slows down re-rendering but no more than I’ve experienced on my old iMac. The 3D mouse seemed a bit sluggish but I haven’t done a comparison with my iMac running Catalina.

I then ran Sketchup Pro under Windows 11 on Parallels on the same macBook and I couldn’t tell the difference between that and the native mac version.

If I’m just being lucky then I wish I could pass that luck on but I don’t know where it’s coming from!

I disable profile thickness and delay is almost gone. Makes it useable again. Maybe its off on yours too. I have been using it without issues now. Cant wait for 100% performance back but 90% is ok.

You indicated in your first post that your MBP was running an M1 chip. It was not supported at the time of your post, however, SketchUp 22 was released 2 days ago and now has native support for the M1 chip, If you have not already, you might consider upgrading to 22.

Oh dude didnt know that. I have 4 Macs. A 2014 iMac,2017 iMac, 2017 iMac Pro and MacBook Pro with M1… That 2014 just keeps kicking lol like most Apple products. I have a 2011 MacBook Air that I updated the harddrive and battery and is still kicking pretty good. Going to go grab it now.


1 Like

Cant use 2022…its stuck in a loop trying to login I guess. Says I have too many products active so I deauthorize all but it still comes up saying I have too many products. I am on the yearly subscription… grrreat! Not sure why they needed to mess with that but ok. Did you have this problem?

Edit - I opened Style Builder and it finally realized I am a valid user of my purchased product…