Palm trees with rectangles (?)


#1

When downloading palm trees from 3D Warehouse the palm trees come with these rectangles which cannot be deleted or hide them. If we erase them the palm tree is erased too. Any way to get rid of the rectangles. Please see the attachment.
Thank you.
Thank you.


#2

Hi Chris,

Perhaps you would post the link to the 3D Warehouse model.


#3

There are considerable amounts of dross in the 3dWH…

Looks like it’s a component made from two rectangular faces, each with the plant-texture material applied to both sides.
To fix it…
Edit an instance [double-click].
Select all and then deselect the two faces by holding Ctrl+Shift and clicking on them.
Now just all of the edges are selected.
Used ‘Entity Info’ and tick the ‘Hidden’ box.
The edges are now hidden [they will still show as dotted if View > Hidden Geometry is ON]
Exit the edit.
To save the Component externally… select an instance and Right-click Context-menu > Save_As…
When you next use that component, e.g. in a new model it’ll now be correct…


#4

Geo,
There is no link for these models. If you go to the 3D Warehouse and just type palm trees you will see on the second row there are a couple and after those there are a few more. This one is under the name: King Palm Tree by KangaroOz 3D but again it is not the only one.

TIG,
I try your method but it doesn’t work, it always hide the whole tree.


#5

Just go into the component and edit by shift-erase (hiding) the offending edges.

Shep


#7

TIG is right. You’ll need to somehow select only the edges, then hide them. They are just the bounding edges of a (textured) face.

  1. if you download the component into a new instance of SketchUp you’ll have hidden edges from the start.
  2. But I suspect that you downloaded the component into an existing model. The component not displays the edges, it is also wrapped into an extra component shell.
    Explode the outher shell. Then apply TIG’s method to only select edges

#8

It gets worse, Chris. Even after you’ve hidden the edges, you’ve still got two big, rectangular faces that will cast big, rectangular shadows. Insofar as cast shadows are concerned, SU sees a transparent png background as opaque.

That’s why when people make a Face-Me or 2.5D (like the one you’re using) component from an image, they generally paint the image on a face that is cut to the approximate shape of the image and then has its edges hidden. The edges are hidden so the outline of the face doesn’t show and the face is shaped like the image so it will cast a reasonably shaped shadow.

-Gully


#9

By downloading the palm tree into a new instance, I could finally hide the edges but as Gully said when I turn on the shadows I get a big rectangular shadow shape which makes the drawing look bad.

Any site where I an get nice trees? (for free :grin:)
Thank you all !!!


#10

Well you can turn down the transparency on the back until it no longer casts shadows. It’s not perfect but it may work depending on your needs.

Shep


#11

One of the unexpected issues is that the original SKP for the King-Palm has its Style set to hide all edges, so when it’s inserted in another Style that does not, then you see the rectangle.
It also has two nested rectangular sub-components inside the main one meaning you now need to do two editing steps.
Also it was no placed at the origin - making its insertion awkward !
Also it’d be a VERY good idea to at least cut a rough outline of the tree in the sub-components, then the shadows will work much better. It takes moments to make a much better product !
Here’s a quick fix.


KingPalmFixed.skp (112.5 KB)


#12

TIG,
As this is just the palm tree that I needed, I downloaded into a new drawing and made it look just how your attached tree looks but when I inserted it into the drawing where I need it, I had to turn off the outlines and edges of the whole drawing and it doesn’t look right. Any way around to avoid it?
Also, when tracing the tree, the lines tend to move in some direction not where I want them to go, like when ortho is on in ACAD. Can we turn off this?
Thank you.


#13

If you edit the sub-component and select all edges [nothing else] and hide them [as explained earlier], then, provided that View > Hidden Geometry is OFF [which is the normal setting when ‘rendering’] then the outline of the re-profiled face does NOT show.
When editing edges make sure your Model Info > Units are set to NOT snap, are say 1mm steps etc.
Ensure that your Style shows Edges and that Profiles are set to be thicker [2 or 4].
Also set View > Component Edit to hide ‘rest of model’ and ‘similar components’ - so that you only see/snap to the one face.
Also take note of the inferencing reports on the cursor, and only click a new edge point when it says ‘on face’.
Once an inner loop is complete its profile edges go thinner, select the face and delete it.
Delete outer edges once you have drawn good loops…


#14

GREAT!!!
Thanks a lot TIG.
It works well that way and even when I import the tree in my model and I click on Unhide all, the tree’s edges don’t show up.
I am writing all the steps down so I don’t forget it for the next time. I really appreciate your help.
Chris