Outliner is slow as hell! (SketchUp 2019)

This post was flagged by the community and is temporarily hidden.

Have you established that this is a problem that many others have? I don’t, for example.

If it’s to do with your setup, there is nothing developers can do about it.

On a side note, do you think your way of complaining will get results? Your post could well be taken down.

1 Like

This is not first time when I trying to rise this problem.
And im not the first who trying to rise this problem.

For the time while I use SketchUp I changed at least 5 computers!
I use SketchUp since 2014 year, and never Outliner(when it visible) worked well.

So yes, I especially wrote my message like that, because it’s truth!
At least 5 years, developers aware about this problem, at least 5 years they doing nothing.

I really don’t understand how it’s possible, that simple TreeView could work so slow, as it works in SketchUp.

Ps,
How many items(components) you have in your scene? If it’s 6 items on the scene, then there is nothing surprising.

My scene contains more than 600 components. Which should not be a problem in the era when smartphones able to artifically render a bokeh on a photo faster than SketchUp updating their TreeView in Outliner window…

Tree View controllers are more complex than you realize, and their performance depends greatly on both the number of entities displayed and the rate at which those entities are being changed in the model.

If you provide more concrete examples of the performance bottleneck you find yourself stuck inside, you will get more useful help. Two things that would surely help right away would be a list of the extensions you have installed and an example of one of the models that you are working on when you see the problem occur.

There are Ruby extensions which cause large numbers of transactions in the model, which consequently impacts performance. Given that your experience is not a universal one (though for you it appears to be happening all the time), it is possible you have one of these installed?

3 Likes

While the slow Outliner is quite known, I agree with John it sounds like yours is extra slow. Maybe you are just making larger models that users in general, or there is a problem with an extension.

Also I would recommend to have a friendlier tone. I’m all for discussing what works and what doesn’t and what possible solutions there may be, but it can can be done in a less confrontational way.

1 Like

Hello John,

Right now I have installed following extensions:

  • VRay
  • CleanUp3

But according to my experience, these extensions don’t affect performance of SketchUp editor.
In other words, I have same problem with and without these extensions.

Here I recorded my desktop to show the problem:

I’m ready to share this model to Skethup team, if this will help them to understand the roots of this problem. (just let me know to where I can send a link to my model).

But I’m pretty sure that it behave the same on any more or less complex model.

From the Help Center …

(Your video shows modeling behavior with textures switched on. This will slow the application down.)


Have you tried using the Outliner in autohide mode ?

Grab your “Outliner” tray and dock it to the left margin. Then click the pushpin button so it slides into a margin tab. This way it will automatically slide out over the model (without displacing it) when you hover or click on the Outliner margin tab. Whenever you move the mouse cursor outside the Outliner tray it will slide back out of view.

This way you don’t force SketchUp to spend the time rebuilding the tree for every click in the model view.

All what you described it’s not a solution, this is just a workaround.
I’ve been using SketchUp for a many years, so I learned most of the tricks to avoid the bottlenecks.

But It’s like - when in your car you got a broken lock of your driver door…
Surely you can get in your car through passanger door, few times, maybe few days, until you’ll finally fix it…
But turning this into “lifestyle”, this is absolutely anormal.

I can’t recall any other software(including 3D Max and LightWare3D) which have TreeView working like that.

So, this post it’s a “cry for help” to developers. To motivate them fianlly fix that.
I don’t need a “yet another way how to workaround it”

Yes, enabled textures slows down the rendering speed. But this not relate to “outliner problem”.
Rendering textures have cost in milliseconds.
Opened Outliner freezes whole application for a few seconds, in some cases it tooks a minutes.

So disabling textures, it’s attempt to save couple matches sticks. While the whole forest burns in fire.

Outliner suffers From a real time update problem. Keep it closed and only open it when you must use it.