Option in Layout to save to DWG is gone?

You don’t have to reinstall. Just resize the sheet that drops down. I can get the options button hiding the file-type selector too.

no, i re-sized and this is the screen I get when I hit EXPORT

Here’s a few examples with the sheet set to different widths. It is messed up!
This is a bug.

44003854

my option only gets wider, no format button

If I reinstall I just need to copy my Key?

Reinstalling should fix it at least temporarily. Yes, you should just need your Serial Number.

ok thanks… my boss is freaking out
thinks I’m a tard, i’ve been doing this for 9 years…
I was almost certain I forgot how to do it… ;0

I can only seem to find 2018 sketchup download… and it will cost me another $240
any idea where to find the 2017 download?

You don’t have to re-install. Click in the red circle, and close the file path view option, and select:

2 Likes

wow I guess I am dumb… that worked… thanks everyone

That doesn’t reset the buttons for me. I’d already tried that. When the files are hidden you can’t resize the sheet and it stays in the state it was in (good or bad).

Export Sheet

OK, well, that pulldown, which is too long to fit in the space, below the Templates folder, is the Format pulldown. DWG/DXF is the last of 4 selections on that pulldown. Hit tab 4 times, then hit space bar (to select that pulldown), then type the number 4, and type Enter. You’ve now selected DWG/DXF. Hit tab, then space bar, to select the option menu. DWG/DXF options should appear. Make your selections, hit enter. Now you can click on Save and it should save.

I don’t know how you got into this mess, but export first and we’ll get those values cleared after that.

2 Likes

One thing this presumes: that you’ve got “All Controls” set in System Prefs ->Keyboard->Shortcuts (at the bottom of that panel). You can toggle it on or off anytime using Crtl-F7. If you don’t do that, you wont be able to get to the Option button.

The underlying issue here is a bug in this DWG dialog in certain versions of OS X - the layout constraints aren’t set properly for the buttons that allow you to choose the type of export. We’ve got a fix in progress for this. Until then, you’ll have to follow Barry’s instructions to access those options.

Thanks,
Marc

2 Likes

So i have 2018 Pro with the same problem. Still waiting for the bug fix please!!!

martin

2 Likes

Have you had any success with the workarounds mentioned above? In particular, if you make that dialog small by clicking on the drop arrow next to the “Save As” field, you should be able to access the “Options” button again.

1 Like

Hi Marc,

I have now clicked on the drop down arrow and can now find the format
options.
I must say that this is rather bizzare and not intuitive at all.
But thanks
Martin.

1 Like

Yeah, it’s definitely a bug and we’ll get a fix out, but in the meantime this will keep you working. Thanks for your patience.

-m

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.