Option and move not copying viewport

Hi there,
Just installed 2020.2, in Layout when I try to copy a viewport with option+move it does not create a copy just moves the viewport.
Has something changed in the update or is this an issue?

It is copying the viewport. Let it render. There has been a change in the way things get moved or copied in LayOut. This was done to help speed up the process so you don’t have to wait for your graphics card to redraw the screen a bunch of time while moving or copying.

My fault, very impatient!

Thanks Dave

1 Like

It does seem to feel and move differently actually.
Is this a response to the well documented gripes with Layout?

I like the way the dims “stick” to the viewport too, very nice touch.

One of the big gripes was that it could be very slow to move or copy viewports on the page. The slowdown was due to the graphics card trying to redraw the viewport for every screen refresh. By eliminating that you should find that copying and moving viewports is faster. You’ll see the same sort of thing with moving other entities as well.

Hi @wmandcoltd Just a quick observation about mouse drag / option key timing from my setup to agree with @DaveR’s solution:

After I mouse drag and release the left mouse button (LMB), I have to continue to hold my modifier key(s) down until the copied viewport is fully rendered. If I release the modifier key(s) before I release the LMB, the viewport behaves like I never pressed the modifier key(s).

The change in LayOut behavior to only refresh the viewport once, not on every screen refresh, is a major improvement for me. My system / graphics is not very powerful, so this change makes LayOut much less frustrating for me.

This latest version of LayOut is actually the first time I have ever had the modifier key to resize the viewport about its center work at all. That, alone, is a nice productivity improvement for me and my middle-of-the road system.

Really? Weird. That has worked for me since the first version of LayOut.

Yes, I think we discussed it in this forum a while back, when I could not get it to work, and you posted an example where it worked as intended for you. Probably due to my middle-of-the-road system capabilities.

Before this latest version of LayOut, I would attempt to resize a viewport with the about-its-center modifier key and it would look like it was going to work. Then, my screen would start flickering, the viewport would “rubberband” bigger and smaller for a while, and then when the dust settled, sometimes after almost a minute, the viewport would be changed in only one direction, not about its center.

BTW, in the earlier versions of LayOut, I tried every “timing” of the modifier key and LMB drag-and-release, all to no avail!

1 Like

I guess I remember that now. It wasn’t so much that the modifier key didn’t work but that the rendering was problematic. Well, that seems to be sorted now so that’s good.

1 Like