Optimize Sketchup for Underpowered Laptop

Hi,

What are some ways to down-tune the graphical settings for SketchUp, so that it will run better on this laptop? It’s okay if the graphics are not as pretty, but we just want it to run well without crashing.

My client is encountering crashing and bugsplatting while using more that one SketchUp 2021 instance on his Thinkpad. Logs did reveal some C++ errors which I am investigating. Here are the specs:

Lenovo ThinkPad X1 Yoga Gen 6
16GB ram
11th Gen Intel(R) Core™ i7-1185G7 @ 3.00GHz
Intel(R) Iris(R) Xe Graphics

Thanks in advance for any advice.

Here are some tips that might help: Speed Up SketchUp: Use Fast Styles | SketchUp Blog

If SketchUp is crashing I would start by going to the Intel website and downloading the latest driver for the Iris graphics. Using integrated graphics with SketchUp most often requires that you turn off the “Use Fast Feedback” option (in Sketchup: Window menu>Preferences>OpenGL). Settings changes come into effect after SketchUp is restartied. Malfunctioning extensions can also cause crashing but display driver problems are the most common reason.