[OpenStudio] Displaced Groups after save and reopen

Hey there!

After I draw my model in SketchUp, I close the program, and when I open it again, the model is all messed up.

When I am opening the file, the preview looks good, but then when the program is loading it, it messes up all the model. I have tried to to another one (just in case the file got corrupted), but it happens again.

I want to use this model in energyplus program (using .idf file), but now I don’t know if that file is ok. After I change the materials/type of walls in energyplus, and then open again sketchup file, it has the new updates…so I am gessing the idf file is ok, but I don’t know if other problems will arise when I run the simulation.

I am a little bit confused why this is happening.

Hope you can help me.


Your image tells us nothing, add the model itself for a better answer.

Here is the model:

Escola.skp (148.2 KB)

You have 9 hidden groups that consist of nothing but guide points, and an assortment of misplaced axes that are most likely causing your problems.
I assume you have either used a plugin or imported your model.
I don’t get the displacement problem you show in your image but I can certainly see problems, but not enough to give you an answer.

Thanks Box,

I already deleted those hidden groups, I guess I created them when I was building my model.

Funny thing, when I saved my model now, it appeared another set of displacements.

And the only plug-in I am using is the Legacy Openstudio.

I hope this is just an error in my pc. I will have to test in other pc in order to find out.

And now there are 18 brown groups?
It’s doubling those groups on each save. Doesn’t do that on mine so there is something going on with that plugin.


I used that plugin now, just to open the idf file, and it showed me the “extra” groups. I believe that this file is the reason for the duplicated groups as well. Also, only 1 of n duplicates has properties…the rest are just empty blocks.

Has anyone used this plugin before?

(thanks Box :wink: )

Hi there, I am the main developer of this plugin. OpenStudio doesn’t use the SketchUp model to store data, rather it uses observers to coordinate the SketchUp model with its own model. These observers do not correctly track undo operations. My best guess is that these geometry issues are the result of using the undo function while modeling.

Check out unmethours.com for help with OpenStudio questions