Opening file

Hello I am using the free web version of sketch up and when I open the skp file it wont let me amend it. Any suggestions why it would not let me male changes to a file?

Sounds to me as if you are opening it with a viewer instead of with SketchUp. Show a screenshot of what you are seeing.

I am opening it using the free web version of sketch up. Here is a screen shot.

Interesting. If you click on the SKP and use “get info” or “properties,” can you see if it’s been set to read only?

I changed it to read and writer for all and still doing it. Not sure what to do now. Just stuck here.

Could you share the file, please?

Can you share the WHOLE screen, please? There is a message at the top of the screen that cannot be seen.

pretty sure it’s

Refreshing the browser to improve stability

1 Like

Yes here is a dropbox link to the file: Dropbox - 1114 (1).skp - Simplify your life

It was saying it is a temporary file. I have renamed it and saved it and it is still doing it. Wont let me push pull or anything other the rotate view.

I opened this in SU for Web… Got the same message about it being a temporary file, but I was able to edit it, just fine…

It DID take SU for Web a few minutes to load the file before I could edit…

This is a bloated file… dozens if unused components… I wonder if that is just slowing your SketchUp way down, making it seem like it is not working.

1 Like

Maybe your computer just can’t handle the file size. I went through the model and did some cleanup starting with fixing incorrect tag usage.
Screenshot - 5_9_2023 , 11_40_56 AM
Then I purged unused stuff.
Screenshot - 5_9_2023 , 11_41_24 AM
And I resized a few excessively large textures.

This cleanup reduced the file size by 93%. Here’s the purged file. See if it plays more nicely for you.
1114 purged.skp (9.0 MB)

By the way, I moved the model to the origin and, since the scenes didn’t work anymore I deleted them. You should get in the practice of keeping your models close to the origin.

Going forward I would suggest that you not hoard unused components and materials. You can purge those in the Components and Materials panels. Also when adding objects from the 3D Warehouse, make sure you clean them up before moving on. Look for low-poly components, too.

I assume this is a hobby thing for you since you are using SketchUp Free. Even so, you should learn to make your models efficiently.


Hum. Thank you for taking the time to do so. I did not create the file. I had someone on fivver create it. I tried the version you sent and still wont allow me to use push/pull. Here is a video from the original file.

You need to open the group for editing before you can use Push/Pull on the walls. Push/Pull won’t work on some of the faces to add thickness, either, due to the angled adjacent faces. That’ll require a different approach. Adding height with Push/Pull is easy enough.

1 Like

Well, you’ve gotten way farther with it than I did trying to open it in the browser version.
At that point, it showed me the model, but the moment I touched my mouse, the whole thing went haywire and I couldn’t see anything. I tried Zoom Extents but to no avail.
Even the main axes didn’t know what to do when I tried to get my bearings.

I didn’t even know they could bend like that. This file truly is a beast.

I hope you were not paying the Fivver designer by the pound! This is a very heavy file, especially for such a simple model. This should be about an hour of design work and should be a simple, light file.


Hey everyone. I appreciate all the input. I think i am kind of at a dead end. I agree should have been real simple. Also the way it is set up I can make simple changes like I need to so kind of stuck with what I got I guess. :frowning:

1 Like

The only thing I see after cleaning up the mess and bloat is that you aren’t using the tools correctly. What is it you really need to do? How will the model be used? Take the time to learn to use SketchUp. There’s instructional materials at

The model is being used for a AIRBNB listing of a cabana I am building. It was not suppose to have the walls on the side of the patio or the front wall at the end of the bed with the door and windows. I will have the place built in 3 weeks so I guess will just do a live video of the actual property.

Like this?

Since it’s a commercial usage you really need to be using SketchUp Go or SketchUp Pro, not SketchUp Free.