"Open Recent" menu item is always empty

Sketchup 2017 on my Mac (OS X 10.11).

The File -> Open Recent menu no longer shows any files. It used to work, but it appears to have stopped working a few weeks ago. None of my other applications have this problem, only Sketchup. In fact, I still have Sketchup 2016 installed and that version of Sketchup works fine. And Sketchup 2017 works with another user account on this same Mac also works. So there’s obviously some preferences file that I need to delete or something.

Can someone tell me how to fix this?

Has anything changed on the system since this last worked? Any new programs installed?

Can you try whether it is maybe caused by corrupted plist files:

  1. Reset (backup and temporarily delete) SketchUp’s plist files.
  2. Restart SketchUp, open a file, quit SketchUp.
  3. Restart SketchUp and check the File → Recent Files menu. Does the previously opened file appear?
    If not, restore the backupped plist file.

If you haven’t tried it yet, the first recourse should be to restart the system. These lists are maintained by a Launch Services daemon that caches them in system memory. If the cache has somehow gotten corrupted, that can cause your problem. Restarting will force the daemons to regenerate their caches and might fix the problem.

If the restart fails, possibly the files where OS X saves the data have been damaged. The file location and format has changed (I think maybe as of OS X 10.12?), so that will affect where you need to look. Your post says OS X 10.11, so I’ll emphasize the older system.

Earlier releases of OS X kept the list of recent files for SketchUp 2017 in


Note that is your personal Library folder, not the system one. Finder hides it by default, so if you don’t see it you will have to either use Finder’s Go->Go to Folder item or to make it permanently visible, select your home folder and in View->Show View Options check the box for “Show Library Folder”.

You can try deleting or renaming that file while SketchUp is not running (if you do so while SketchUp is running, the system will generally overwrite the plist from its cache when SketchUp closes and restore the previous values). You may also have to log off and then back on to get the change to stick, as the system caches user preferences values in memory during a login session. Don’t delete or rename other .plist files, as that will kill off all of your other preferences too!


I’m embarrassed to say that rebooting fixed the problem. It never occurred to me that the Launch Services daemon would be corrupted for only one program, but sure enough, that sounds like what my problem was.

Thank you very much.

1 Like