Oob terrain plugin

#1

Created terrain using Oob Terrain plugin from Stefan which is great btw, but was wondering if possible to “hide” the mesh faces that show throughout the landscape.

I’ve attached screenshot of the model, which is Mt. Desert Island in Maine.

#2

Oops, where can I attach the screenshot to this post…new to the forum so forgive my noobiness…

#3

7th button from the left above the window where you type your message.

#4

Thanks sdmitch! Besides the fact they’re very tiny, (I’m on a 4k display) and light grey, I totally missed them.

#5

OK now that sdmitch was kind enough to show me where the uplaod image button is I can post the image relative to my first question. I was able to discover smooth/soften then check soften coplanar in the soften/smooth edges dialog box got rid of all the triangular terrain segments. However since Oob terrrain builds the geography from multiple pieces you can see in the screen shots all of them as separate objects/boxes and then deselcting them the black border lines are still visible.

I’m trying to hide or eliminate those lines so the model presents as one clean looking landmass. Do I need to combine all those individual groups into one? Thanks in advance for any help or advice.

#6

Hide those edges.

#7

To expand on “hiding”.
Change the view temporarily to Wire-frame mode - so you only see just the edges.
Select all visible edges with a fence and in Entity Info dialog check the ‘Hide’ box…
Go back to a Textured view mode.

#8

I suppose (possibly) a way could be to use a style with the edges turned off and set a scene using that style?

#9

Yes. That would work unless you want to show edges on the border of the terrain or on other parts of the model.

#10

Thanks everyone for the various solutions. Tig, I’m not sure what you mean by “select all visible edges with a fence”…?What do you mean by fence. I selected all the boxes, went to entity info and that dialog box only shows these variables:

#11

You have to open each component or group for editing to gain access to the edges that need hiding.

#12

Also you need to expand you Entity Info dialog [bottom right down-arrow] - then you can see extra options like ‘hide’ etc…
As @DaveR says, because you have groups you must either select them all and ‘Explode’ - then hide edges - OR edit each of the ‘containers’ in turn and then hide edges inn each one…

PS: You can ‘Select by fence’, by using the Select tool and picking two corners of a ‘fence’ - keeping the mouse button pressed as you do so.
Picking the corners right>left and left>right gives different result if some edges are not wholly within that fence - it’s SketchUp 101 [or perhaps 102] - look up the help files…

#13

the easy way “Visual Merge

#14

is each one a ‘solid’ group?

I can’t tell from the image and I don’t have extension…

if they are, Select them all >> R-Click >> Outer Shell would be my choice…

john

#15

Thanks for all the tips guys. To answer John; yes, each section of the landscape is a separate group. After selecting all, I right clicked but there was no Outer Shell option.

Seems like the only way I am able to make those border lines hide is to edit each group, then shift select each line segment, then “hide” or delete them…here’s screenshot attached. Very time consuming…

I’ve also attached a screenshot for TIG; was not able to find “hide edges” (screenshot attached). Everyone, thanks much for your time, patience and suggestions with this issue. I appreciate it being part of a community where you veterans are so willing to help out the newcomers.

#16

As @Julian_Smith suggested, Eneroths Visual Merge plugin might automate this time consuming process for you.

#17

TIG never indicated there’d be a menu item for Hide Edges.

Switch the Face Style to Wireframe. Drag a selection fence around the model to select the visible edges only. Then either right click on a selected edge and choose Hide or go to the Edit menu and select Hide. Switch the Face Style back to Shaded with Texture.

#18

Dave R, thanks much. I selected each group in wireframe, edit group, drew fence around it, selected “hide” and border lines were gone.

I misunderstood TIG’s post. Just assumed there was a “hide edges” somewhere…

Thanks again to all of you for your help. Think I’m gonna get Eneroth’s Visual Merge see how that works.

#19

Tip: use hide rest of model, (Set up a short cut in "windows>preferences>Shortcuts) double click each group and the rests of the groups and components will be hidden, then select the edges you want to hide, wire frame will help. image

#20

I use SelectionToys to select all the lines in the mesh and hide them. So many other uses for that plugin as well!

Regarding Oob - works great, but I’m not getting any Google Imagery when I press the button. Still on the trial but I will be buying if I can get the image to work. Terrain looks great - although to me it is a guessing game on how large to set the area.