On Startup of SKP 2019 - "SketchUp cannot start due to a license error."

Yes, clean installation of SketchUp Pro 2019 as administrator from this link. It’s bizarre because it won’t even initialize, I just get that message immediately. I tried opening Layout and Style Builder and got the same thing.

I did some digging and found the license manager page and can see a few of the licenses we own are on “HOLD.” Could that have anything to do with it even though there shouldn’t be one associated with his SKP2019 yet?

“on Hold” means that an old license was auto-upgraded to the latest version and will cease to work (single user license) or cease to work after 60 days (network license) as soon as the latest version gets activated.

besides the Trimble license server being down… an active internet connection w/o a password protected proxy and w/o a firewall blocking neither “sketchup.com” nor “google.com” (the latter for the being online check) is required.

Limited user rights blocking to write user data to the concerning Windows user directories? Try if launching SU itself by “right-click > Run as Admin” helps.

Being logged in to the appropriate Trimble ID is obvious.

1 Like

Tried it all but thank you!
I’m talking with a Tech now. Will update with solution.

Any luck on this, I am having the same problem. I have update half a dozen computers with the very same install file without any trouble, except for this one. The previous install of 2018 still works fine.

Thank you for the information you’ve provided so far. We are working to get to the bottom of this.
If you have run into the “SketchUp cannot start due to a license error.” Please let us know what sort of system you are running on.

  • Mac
  • Windows PC

0 voters

Hi, any updates on this. We have many users but at present it just affects me. I have tried all of the above remedies but to no avail.

This is a situation where our team needs to dig into this on an affected system. We cannot recreate the issue in house (we’ve tried). We have had some great participation from users allowing us to conduct remote sessions, but we are reaching a level where the troubleshooting can get a little destructive and we don’t want to break anyone’s system. I’m trying to see if there’s a way to capture a drive image from an affected system and try to reconstruct the issue on a system in-house.

half joking anyone with 2019 have the “Sketch up can not start due to a license error” issue and are willing to ship us their computer for a couple of weeks of diagnostics? ¯_(ツ)_/¯ It’s worth a shot.

Is there a fix for this yet, my old pc just broke and I’ve started using an Acer N15Q1 . I’m having the same problem as the others new installation, sketchup doesn’t even open to licensing page.

When you installed SketchUp on this new machine, diod you right click on the downloaded installer and select Run as administrator? If not, rerun the installer using Run as administrator and when prompted, select the Repair option.

image

I’ve tried running the repair and still the same problem

Which license? Classic or Subscription?

I have a classic license but I have not had the opportunity to put it in, as sketchup will not open.

Did you try contacting Customer Support?

A quick update on this. The dev team has this issue as a top priority. The problem is we cannot recreate it in house (as often the case with software companies). It is not related to classic or subscription account types. It seems always an issue with Windows systems. It is mostly reported by Dell users, but there are a handful of others. I’m at the point where I’d like to see if I can get an image of a user’s hard drive, buy a computer of the same make / model / specs, image that drive with the customer’s image JUST so we can have a system to experiment on. If you’re system is exhibiting this issue and you are going to be in the Northern Colorado area, please reach out and we can show the team.

P̶o̶s̶s̶i̶b̶l̶e̶ new workaround
We are theorizing that the issue is related to Windows update 1903 and a corruption of the Windows user profile. This update has caused a number of headaches for folks, but hasn’t affected everyone. For those of you with SketchUp Pro 2019 who are seeing “SketchUp cannot launch due to a license error”, would you mind giving this a try.

  1. Create a new Windows user account by following these simple instructions: https://www.webucator.com/how-to/how-create-second-user-account-windows-10.cfm
  2. Log out of Windows and back in as the new user
  3. Try launching SketchUp Pro 2019
  4. If it works, try logging out of that account and back into your main Windows account. Does SketchUp Pro 2019 work?
  5. If that helps OR doesn’t help, please let me know.

UPDATE
Windows 1903 update seems like it could be a red herring since we’ve recently seen a couple of examples if this error on Windows 1803.

A small update… I’ve been present for 3 fix attempts using the above suggestion and none of them worked. I have heard that an in-place upgrade worked for one user, but there are risks. Find out more about this suggestion here: https://www.computerworld.com/article/3262979/how-to-fix-windows-10-with-an-in-place-upgrade-install.html

I would try the Windows user solution, but I’m running Windows 8.1, not 10. I have a Dell (Alienware) laptop. I just attended a two day training workshop through SU Trainer where the program worked. I came home and tried to open it and I got the license error code. I too reloaded the program and Windows said it was
fixing the corrupted files with the reload but this did not work.

Good afternoon!

Just wanted to throw some extra info in here, if it helps the troubleshooting process.

I have one user at one of my client offices that is having this issue. I had her restart the computer, and the issue went away, however, she just notified me today that she has to restart pretty much every day because whenever she uses sketchup, she gets this error. The workstations here are set not to sleep, so it’s not a sleep/wake issue. The restart fixes it for the day, but for some reason, it comes back the next day.

I hope this helps in any way.

Interesting. The first thing I did was restart and it had no effect.

I have had a customer report that the error went away when he updated to Windows 10 build 1909. I have done that update on my machine, but I was never able to show the issue, to know if 1909 really helped.

If any of you are still seeing the issue under build 1903, and were thinking of updating to 1909, let us know if it helps with the license error.