Older version drawings look weird when opened in Sketchup 2018 pro

#1

I just purchased 2018 and license. I opened a few of my older designs, 2014, 15 etc and they all look really weird. Sliced up, wrong proportion etc. Not at all usable. Anyone else had this happen? Could it be new defaults that I need to toggle. Help!

0 Likes

#2

Posting an example model (or 2) file always helps so the gurus can have a first hand look.

0 Likes

#3

It’s so bizarre looking I don’t know if it would help lol. How does one add an attachment, don’t see it.

0 Likes

#4

Groups look like line drawings, some proportions are way out of whack. I will post a few screenshots if I can figure out how.

0 Likes

#5

click on this symbol and navigate to the file to upload.

upload

0 Likes

#6

… or on Windows you can drag and drop allowable file types files onto the post edit box to attach them.
(When you first open the edit panel to make a post, there is help text telling you how to attach files. It disappears when you start typing the post.)

0 Likes

#7

Screenshots of what you see would also help.

0 Likes

#8

sketchup%202018%20weird%202 sketchup%2018%20opening%20older%20version%20file

0 Likes

#9

Here you go

0 Likes

#10

Do new files you create in SU 2018 look ok?

If so, I don’t have a clue where the problem lies. SketchUp 2018 should be able to open files from older versions (though not vice versa), and certainly without the kinds of distortion you report. It would help if you could upload a .skp model file instead of images so we can see if we also have problems.

If not, it is likely that your graphics adapter and/or its drivers aren’t up to the increased OpenGL requirements of newer versions of SketchUp. There was a major rewrite in 2017 of how SketchUp uses graphics hardware. Your profile doesn’t really say what graphics your computer has, though “HP built into laptop” leaves room to suspect it may be Integrated Graphics. If that’s the case, you could try obtaining newer drivers from Intel (or whoever made your graphics) and see if that helps.

0 Likes

#11

Could you not resize the images? I can’t even see what image is from what SU version.

1 Like

#12

if using SketchUp 2016 you can disable “Window > Preferences > OpenGL > Use hardware Acceleration” to fix display output artefacts in connection with low-end graphics sub-systems.

1 Like

#13

That is the first suggestion that makes any sense to me, thank you I will investigate.

0 Likes

#14

What is your complaint exactly? It is 2018.

0 Likes

#15

Your profile indicates you are using SU 2016.

Why don’t you upload an SKP file that exhibits this strange appearance so some of us can check them out on our machines and compare what we get with what you’re seeing?

0 Likes

#16

Which one is SU 2018? There are two screenshots with differently positioned toolbars. Is one the model as it is supposed to look and the other the unexpected behavior in SU 2018? If so, which one is which?

0 Likes

#17

It is now fixed, turned out I needed new graphics drivers, although when checking the display driver for updates using Windows control panel it said I had the latest drivers.

The support team at Trimble sent me a link to Nvidia to update and it worked.

0 Likes

#18

as Steve has mentioned above.

MS distributes their own basic driver variants, the latest driver version can typically be obtained by the manufacturer of the hardware… which is according to your profile a “HP built in to laptop” (which means probably an “intel HD”?).

• nVidia GeForce Drivers: Download
• nVidia Quadro Drivers: Download

0 Likes