Number pad in SketchUp Ipad …. Glitch?

I dunno if this is a bug or not but I am often drafting off of client photos (abusing divide/multiply to use visual clues to guess measurements, etc…). And I’ve noticed that when I am in the split screen the num pad has a tendency to… skew?

The buttons get bigger or shift away out of the bounding box. Usually it looks like this but I think it has looked a little different at other times.
Is it a feature that’s doing something? Am I crazy?

EDIT:: here’s another, much more extreme example. (makes me feel less crazy for thinking it’s a bug :wink: )

Whenever this happens, the only way to fix it is to hit save and back out of the file, then go back in.

Hmm, that’s an interesting find. I can’t say I’ve ever used split screen with it.

You’d love Match Photo for this task, BTW, but iPad doesn’t do it, at least yet. I think it’s a natural addition for iPad since iPad’s come with a camera built in to take pictures with.

1 Like

Can you say how you got into split view while in the SketchUp iPad app.

Sure!

  1. SketchUp open first
  2. 5 finger pinch to exit
  3. Secondary program open (usually photos, Gmail, Google, or Pinterest) in this case Gmail attachment
  4. Nudge up from the bottom for recently opened programs, select SketchUp and drag it to the right side of the screen.
  5. Slide adjust between the screens using the middle handle until the reference program is .25 and SketchUp is .75 of the screen.
  6. I sometimes (though rarely) will slide back to 50:50 if the reference photo is too small, but usually I just pinch zoom on the left screen.

There is also a fair bit of 5 finger pinch to exit the new combined screen to use other programs, and then coming back into this setup saved by iPad as if it were one program (this is when the extreme version happened)

I have actually upgraded to desktop! I just haven’t had the time to sit and do all the tutorials yet so I’m still plugging away in the iPad. I’ll still use the iPad all day when out on job sites, but I’m looking forward to asking a bunch of dumb questions about desktop pro though. :grin:

Also, you can probably see it, but should be mentioned, I have moved any toolbar that moves over to the left. Especially the measurements. I absolutely could not get to them through iPad’s middle top ‘three-dots’ menu.

Thanks for reporting this @Danimaupin. We’ll take a look.

1 Like

You can also tap the 3 small dots at the top of the page once your in your model to get into split view. The SU number pad when docked overlays the dots making them hard to see when in split view, but they still function.
Bob

In any view, when the number pad is centered, it fights for attention with the dots. This was a major source of irritation at the beginning and then I learned you could move the menu and haven’t even thought about it since. I don’t even consider it a problem.

I actually only mentioned it in case my moving the menu was a part of the problem.

@Danimaupin Hi, May I know your iPad and iOS version details to help us reproduce the issue?

To @preethi_vas point: I picked the smallest screen I could (iPad Mini 2021, 6th Gen) and tried to reproduce it, but can’t. Here’s the screenshots:


Sure.

Software: 15.5
Model: iPad pro (12.9-inch) (5th generation)
Still have over 210gb avail memory.

I can play around with it more after work and see if I can narrow down when it happens

1 Like

@Danimaupin Thank you. Will take a look.

I tested on the original 12.9" with iOS 15.5 and couldn’t get it to repeat. I don’t have 12.9" 5th Gen in our stable of devices that I’m aware of. Do you have text size adjusted in any way?

What is interesting is that I can select the measurement, then move the box, and weirdness ensues - note the blue dots and the menu are not connected to the selected measurement:

That iPad mini screenshot makes it very clear that iPadOS split screen should allow for an horizontal layout.

I remember it has happened to me a couple of times when I was working late night for a competition.

It was a whole screen (not a split screen), on ipad pro

i moved out of my file to home screen and came back, or closed sketchup and re-opened, or maybe turned off the ipad and came back, i do not remember but it came to normal.

I may not be able to duplicate it now even if I intend to, but just to let you know it had happened

Thanks,

1 Like

Just tested on iPad mini 5th gen When you tap the three dots and the right image you get an overlayed panel that can be moved around the base screen thus keeping sketchup as a full panel and a reference screen for your reference image. When tapping the left image you get a split screen.

1 Like