None of my extensions are working all of a sudden

I opened Sketchup today for the first time in just over a week and none of my extensions are working. Haven’t changed anything system-wise, but did just download the latest version and install it. After Sketchup starts, I get an error screen stating that there were load errors (I have attached a screenshot).

Windows 10 x64 with all current updates, Sketchup Pro v22.0.354 64-bit

The culprit is very often the first item in the list of error messages in the Ruby Console.

Thanks for the reply.

I’ve tried everything…uninstalling and reinstalling by right-clicking and selecting “Run as administrator”, deleting all Sketchup folders and reinstalling, I contacted support and they had me download the offline installer…none of it worked. Even after reinstall, the native Sketchup plugins won’t load. I checked permissions on the folders and they are all correct. This is weird.

What if you remove all extensions except the native ones?
Then you can add them back in stages, say, in groups of three until the error messages start again. This would eventually lead you to the culprit.

What changed on your computer, updates etc?

Just downloaded some updates for drivers and the BIOS and somehow my permissions got all screwed up. Was working with Sketchup Support and they had me add a new local account, and install Sketchup, and it worked perfectly.

I wiped the whole computer. I’ve already spent almost two days on this and I have deadlines at work.

Thanks for the replies guys.