No memory release when closing Sketchup

Hello to all,
I have a recurring problem with Sketchup Pro 2021 on Windows 10 Pro.
When closing Sketchup, Sketchup is not released from memory. It still appears in the task manager.
I have to kill the task manually.

What is the problem and how can I fix it?

Thank you very much.

Do you get the popup panel which is asking what to do with the current model?
If not, it might have gone offscreen.
Try to reset the Workspace in [menu] Window > Preferences
Or this combination of key’s:
M *
Arrow key
Move mouse

*change this letter if Windows language is different

the pop-up is displayed well in the middle of the screen.
I don’t have a problem with a Sketchup window not closing, I have a problem when the Sketchup window is closed, the task “Sketchup Application” is still active in the Task Manager and I have to kill it manually.
I reset the interface anyway. Not sure if this solves my problem.

Did you install SketchUp properly ?
You can repair it anyway - no adverse affects…
Close SketchUp.
While you are logged into Windows as your normal-user account do the following.
Find the current SketchUp installer’s exe file - usually in your Downloads folder.
Select that file’s icon, right-click > context-menu > “Run as administrator”
When the dialog opens choose “Repair”
When it’s done, restart, and see if SketchUp behaves differently…

I just performed the repair in Administrator mode.
I opened Sketchup, closed Sketchup, and still the same problem. The “Sketchup Application” process and 3 “sketchup_webhelper.exe” processes are still running in the Task Manager.

What you say is ambiguous…

I just performed the repair in Administrator mode.

this could mean:

  1. you logged in as an administrator, used ‘Run’ and did the Repair, OR
  2. that you logged in a your normal user account and used the "Run as administrator’ way, and did the Repair.

Option 2. is the right way…

I have done option 2.

Have you tried uninstalling v2021 and restarting, then reinstalling it from scratch - remember to use “Run as administrator” to do this too…

Any better ?

I have uninstalled and reinstalled everything in Administrator.
For the moment, it works.

I blame Windows for this issue. The more memory SU is using the slower Windows is to close the app (as viewed in task manager) after I close SU.
It does interfere with VRAY rendering memory use - minor issue.

I have the same problem and I tried all of the below. It is so frustrating having to go to task manager to stop sketchup 2021

What version of Windows do you have? The latest is 21H2.

I have the latest version of Windows - 21H2.
The memory release issue may have only been around for less than a year.

With my experience as a deep developer for more than 20 years I say that’s unlikely that the reason is Windows. In all cases all of such issues where always app implementation issues. Sometimes complex to find, but blaming Windows is easy but nearly always wrong.

Yes, just a wild guess on my part. I only have a few facts to work with. I didn’t have a problem with SU memory release on a 16GB WIN laptop, but switching to a 64GB desktop, I now have memory release issues.
There used to be memory release issues with PhotoShop ~10 years ago and Adobe wrote some work around code which I don’t remember being too helpful. Scratch disk planning was a great time waster too.

I started wondering if your problem might be caused by a plugin. Are you running plugins like renderers that are dependent on external code or applications?

I am running the VRAY plugin. It does not have specific memory release issues that I am aware of.

I have noticed that in task manager, SU is holding the bulk of the memory that VRAY is actually using, indicating it is a VRAY problem (noticeable when using 50GB+ memory).

Hello to all,
I’m back to inform you that the problem is back.
9 times out of 10 I have to kill Sketchup tasks through the Task Manager.

I see that I am not the only one to encounter this problem.

i have it when using rendering

This topic was automatically closed after 186 days. New replies are no longer allowed.