Newb with elevation issue


#1

not sure how to search for this issue here because i’m not sure what i did but would love to get my floor plan back to the correct elevation (below susan) any info would be great. thx jim


#2

It looks like the floor plan is correct, it appears to line up with the origin point.
Perhaps you simply moved Susan. Select her and lift her up with the move tool.


#3

By default, SU draws on the Ground Plane when the camera view is predominantly looking down.
The Ground Plane is defined by the red and green Drawing Axes when they are in their default location.
Best practice is to leave the axes in their default location and begin the model on the ground plane.

It’s impossible to discern from your screenshot whether you’ve moved the drawing axes and the floor plan OR if you’ve inadvertently moved Susan below the ground plane.

First confirm the axes are in their default location.
Then you can move things to the appropriate elevation.

Right context click on any of the axes. (Do this in empty space, away from any geometry)
In the Context menu that appears:

Place … Launches the Axes Tool
Move … Opens the Axes Dialog
Align View … Places the Camera on the blue axis facing the Origin
Reset … Returns the axes to their default location.


#4

Thanks so much guys. Geo couldn’t get the ‘Right context click of the axes’ action to work no matter where I right-clicked outside the geometry?! But I did go to tools and under the AXES option I clicked on it and now Susan is standing above. Not sure what I did (if anything) but it looks right now. I should add that all of this began once I tried to Push_Pull one of my walls upward and for whatever reason to raise my wall 7’7" I had to put a minus before the value as shown in my pic below. So is the negative -7’7" the correct value? I had assumed it would be a positive measurement from the ground floor up? Thanks for any additional info you may have. JIM


#5

The right click on the axes can be a little confusing.
Specifically you need to right click on the red blue or green lines away from any geometry, not just in open space.


#6

You have to right-click pretty precisely to get one of the axes, but using the Axes Tool as you did is a perfectly ok alternative.

Looking at your picture, I suspect that you drew the basic floor outline at z=0 then drew wall outlines within the floor? If so, you fell victim to some SketchUp quirks.

First, when you draw a Face at z=0, SketchUp helpfully orients it so that the “inside” surface is up and the “outside” surface is down. This action is based on an assumption that you will most likely create objects above this Face, and then the bottom surface will be “outside”. In your picture, the visible surfaces look dark, which makes me think they have the default material and the “inside” surface of the floorplan is pointed upward.

Second, when you push-pull a Face that is inset into a larger Face (such as your wall outlines within the floorplan outline), the tool by default leaves a hole in the larger Face and orients the surfaces of the push-pulled extrusion consistently with the original orientation of the push-pulled Face. This is exactly what you want if you are trying to punch a hole through a wall or make a bump out from a wall without leaving a spurious hidden Face inside. But it isn’t what you wanted for your walls - you don’t want to leave a hole in the floor! For this case you need to toggle the action of the tool by pressing ctrl (option on Mac) to tell it to create a new starting Face at the original position during the push-pull. In addition to not leaving a hole, this toggle will cause the outer surfaces of the extrusion to be “outside” surfaces regardless of the adjacent larger Face.

Third, the sign convention in push-pull is always that positive means in the direction of the “outside” normal and negative means in the direction of the “inside”. But in cases where the tool helpfully reverses the starting Face for you, every direction is positive!

In your model these three quirks all lined up so that when you push-pulled an inset wall upward from the “inside” of the larger floorplan Face, it was treated as an inside extrusion in the negative direction. Clear as mud? The attached animation may help.


#7

Ctrl on windows.
Alt is the autofold toggle for the move tool.


#8

Ack, we Mac users always get that wrong, just like Windows users always get our toggle keys wrong. Sorry about that! Edited the post above to correct this. Thanks!


#9

Thanks so much ‘slbaumgartner’ for explaining, it totally makes more sense, and yes I’m on a mac. I tried to toggle a section of wall with the ctrl method you described but not sure it created a new starting face because the dimension was still a negative?! So at what point do I click ctrl to toggle push-pull tool? Before or after I select the section or before or after I push-pull? Either way I try it the measure is negative, which I assume it hasn’t worked. In the pic below I have selected the wall I want to raise and clicked ctrl and this box comes up, If I select the wall then go to the push-pull tool and click ctrl it does nothing and measurement is negative. Confusinhg, thanks again for anymore clarification you can offer. Jim


#10

To me it looks like your faces are reversed and when you pull up, SU thinks you are pulling down, hence the negative measurements. You faces should be white not blue gray. Try reversing the faces and pull up again. See if that works.


#11

How do I reverse the faces?


#12

Box and my correction may have confused you. On the Mac, you press option/alt. It is ctrl on Windows! Also, the menu you show results from holding ctrl down while you click when the selection tool is active (ctrl-click is equivalent to right-click on a mac), so you haven’t yet activated the push-pull tool.

You must first activate the push-pull tool. Then, when you press the option key you should see a little plus sign appear next to the push-pull cursor (it is visible in my demo clip above). You press and release - don’t hold it down. Each press and release toggles back and forth between the hole-cutting and new Face modes. The mode switches back to hole-cutting automatically when you complete each push-pull, so you have to repeat the toggle for each new Face operation.

Ironically, the Reverse Faces command is on the right-click context menu of the selection tool that your screenshot shows! Right click and pick this context-menu item (or get it from the Edit->Face->Reverse Faces top menu item). The outside and inside surfaces of the selected Face(s) will be swapped.


#13

Ok think i got it, without clicking option/alt I just selected the wall I wanted to raise to 7’7"right clicked and reversed face and bingo! Section turned white and ended up being a positive measure as pictured! So slbaumgartner does that mean that it created a new starting face or no?


#14

No, it means you reversed the starting Face before the push-pull. If you orbit your model and look at it from below you will see the hole through the floor.


#15

Well did it with the + option/alt and got the positive measure. Wall section turned white too and did not have to reverse face. No matter how many times I tried (not holding down option/alt etc.) I still wound up with a hole. Does this hole really matter? I basically wanted a positive dimension for planning walls, items in my space, which thanks to you all I have learned. So much left to learn but I have found this SU forum super helpful so far so thx again

.


#16

Without ability to orbit the model myself, I can’t be sure, but it looks to me like that is a “inside” Face, not a hole. If it was a hole, one should be able to see the interior Edges of the wall through it, the way you can see in my animation when I pull downward in “hole” mode. The inside-oriented Face is what push-pull will leave behind when the create-face mode is on and you push-pull upward.

For the attached screenshot, I created four rectangular faces inside the larger one. I reversed the two in the rear (+green direction). Then I push-pulled the two on the left in “hole” mode, and the two on the right in “new Face” mode. Finally, I orbited the model to look at the bottom. You can see the difference between leaving a hole and leaving a new starting Face. The quirky thing is that the new starting Faces are oriented with the “inside” surface downward, but they are there.

As to your other question, the answer is subjective. If the hole doesn’t affect what you want to do, it doesn’t matter. One place it could come to matter is if you want SketchUp to consider your wall to be a “solid”, which it won’t do when the bottom is open.

One final note: you may notice that my screenshots show a blue color on the “interior” surfaces instead of the gray used by SketchUp’s default material. Many of us change the “interior” (aka back) color of the default material to make it more obvious which way a Face is oriented. The illumination of surfaces changes depending on the direction you view them, and sometimes it is hard to tell a dimly lit “outside/front” surface from a well-lit “inside/back” surface with the default gray material that ships with SketchUp. If you like this change, save it in your default Template so that you will get it every time.


#17

PS: in your screenshot, you appear to have “back edges” viewing mode turned on. So, you are seeing dashed representations of non-visible edges. That is different from seeing the solid representations of visible interior edges as in my screenshot.


#18

Wow so SO helpful slbaumgartner! I get it and definitely can concur that this is not a hole after I turned off the "back edges"view. You certainly have clarified my concerns and this tip/option on changing the inside default color material can be found where?


#19

I looked around some and couldn’t find a unified discussion on choosing the default back face color (there might be one, I just didn’t see it…).

The default front (aka “outside”) and back (aka “inside”) surface colors are controlled by the active style. If you haven’t selected a different one, this will be the default style set by your selected Template. To edit the style:

  1. Open the styles window
  2. click the little house icon to make sure you are looking at styles “In Model”
  3. Select the default style, which may be the only one shown or may be the first one at the top left if you have created other styles while editing your model.
  4. Click the edit tab in the Styles window.
  5. In the style edit panel that appears, you will see a row of buttons near the top. Each of them selects a different set of aspects of the style. The second button is for how Faces are displayed. Click this button.
  6. At the top of the Face style panel you will see buttons for the front and back colors. Click one of these to change the color.
  7. A color selector window will open. These are quite different on Mac vs PC, but each offers various ways to select a desired color. On a Mac, it is the standard system color chooser. Choose the color you would like to use. It immediately becomes effective for that style on the current model!
  8. If you want to make the style change permanent, you can either save it in your own collection and reload it to models as needed (right-click on it in the Styles window and choose Save As), or you can save it in your own default Template. To do the latter, create a new blank file, edit the default style as above, and then do File->Save As Template… You will then want to make your new Template the default in your Preferences/Options.

#20

Done! Thx So much again slbaumgartner!! Jim