New to 2019 can't set dimensions on initial geometry?

Sorry for being a late adopter/late to switch but for reasons like this we typically stick with versions we are fast with until we absolutely must switch and can learn the changes.

Have just started switching to 2019 (and realizing why I am slow to switch), is this a glitch on my end or something new in 2019 that you start the program or start a new file and you cant set the size of your first drawn geometry? Start SU, draw a rectangle, punch in the dimensions for the rectangle, and absolutely nothing happens. Immediately draw another rectangle or any other shape and its back to normal. Is there something foolish now where you have to establish a drawing plane? If so can this be turned off?

Loaded up 2018 and its as normal.


1 Like

It wasn’t a problem for me. How large is the rectangle you are trying to draw? Are you sure the camera is zoomed correctly to show it? What are you using for the separator between the dimensions? Are you using the same one that is displayed in the Measurements window when you drag out the rectangle?

Your profile says your operating system is ‘10’. Is that Windows 10? If so, did you install SketchUp 2019 by right clicking on the downloaded installer and choosing Run as administrator?

Thanks Dave,
2018 running on laptop screen, 2019 running on extended monitor. Been running SU since inception pretty much. 2018, brand new file, “R” (rectangle), click, drag, release, type 25, 40 enter… rectangle 25x40 (inches, feet, whatever model units). 2019, same deal “R” click, drag, release, 25, 40 enter… nada, nothing, zip. Leave the rectangle sitting there drawn as-is and draw another, 25, 40… vualah… its just fine. Swap monitors, same thing, try different templates, same thing. Interestingly, even after you get the first geometry in and the world rights itself if you select all and delete everything you then again have to draw anything to get the input to work again.

I have no clue about run as adminisrator. SU now says new version, install now, thats likely what I did to have 2019 land on the desktop.

And yes… “10” would be windows 10. Will try reinstall. SU is painful to upgrade which is why its avoided. extensions on 2019 throw up CleanUp errors on startup in 2019 and so on. Really shouldnt be such an involved process in this day and age. Again, why (in business) when I see the “new version of sketchup is available” its usually avoided like the plague because its never a painless process and when your livelihood is crimped its easier to just stick with a version your good with until you have a day or two to waste chasing stuff like this.


Find the downloaded installer, right click on it and choose Run as administrator. When the options appear, choose Repair.

It shouldn’t be painful. With the right approach it should be very methodical and simple to do.

Not unusual if extensions have been copied from an older version. Extensions commonly need updates to be compatible with newer SketchUp versions. Many get updates even between SketchUp releases. Few users take the time to keep extensions up to date when revisions are made to them so they wind up with old, outdated extensions. Best practice is to install extensions fresh from their sources.

It doesn’t have to be an involved process but just as in woodworking, you have to use the right process. Changing out the knives in my jointer is a pain but it’s a necessary thing and with the proper process, it’s not that awful.

Playing around here again and it seems like its got to be something setting based. Parallel projection, top view, draw a rectangle, cant set dimension. Draw any other shape WITHIN THAT RECTANGLE (like you drew a working plane) and you are fine. Draw a circle outside of that rectangle, entering in any dimension does nothing. Draw any shape within the first shape… all works fine.

Considering what you wrote in your profile I hesitate to ask but what is the graphics card?

Draw a rectangle that doesn’t show for you. Save the file and upload it so I can take a look.