New Textures failing to load?

Hi everyone, hope everyone is surviving these challenging times. I am working with Sketchup Pro currently Version 21.0.392 on a Mac:
Processor Name: Intel Core i7
Processor Speed: 4 GHz • Number of Processors:1
Total Number of Cores:4L2 Cache (per Core):• 256 KB L3 Cache:8 MB
Hyper-Threading Technology:Enabled
Memory:64 GB• MacOS 10.14.6
In the past I have always developed specific textures to fit a project, now however when I try and import these no matter what I name them-.PNG, Jpg they are NOT dropping into the materials pallet as before?

Is it possible you are importing them as images, and in the past you imported as textures? If that’s the case, you can right-click on the imported image, and choose Explode. It then should show up in the Colors palette, Color in Model set.

Thanks Colin I will check. I really do not intend to import them as Texture only into the texture pallet it has always worked before? I have folders with various names like Photos, Fabrics etc. Never ran into this is the almost 20 years with the program? I do belong to the Sketchup Texture Club, although I have not tried to load any of those at this point.