My sketchup comes on but doesn't show the grids instead it's all blank

My sketch up doesn’t show the grids and the guy when it comes on instead it is grey and blanc but everything else works and I cant draw

Graphics card isn’t up to the task. In SketchUp go to Window>Preferences>OpenGL and turn off Use Fast Feedback.

1 Like

I wish I could switch off “Fat Feedback” … but Hey it’s Thanksgiving time. :wink: