My PC is so slow, I need HELP!

Hi guys! I really need help before being obligated to change my PC :weary: I a ASUS Vivobook 16” last years because i needed it for school ( interior design) . It was pretty expensive but i choose this one because it has all the spec needed for rendering, modeling… So now a work for a designer, she send me sketchup files and i help her do some things on it or on Layout. But it’s soooo long i’m always waiting even if i do a little zoom . It’s frustrating because i have alll the minimum spec and more for the use of sketchup . The my college use a mac and all her file are from a MAC i don’t know if it can be the problem?! I just need help i don’t want to buy a 3000$ MAC when i already have a 2600$ PC :joy::sweat_smile:

1 Like

I wouldn’t be jumping to change computers just yet. I expect the thing that will help more than new hardware is to make sure you have your SketchUp models under control. Optimizing the models tends to have a bigger impact on performance improvement that spending more of your shekels on new hardware. If you share a SketchUp file that is causing you trouble we can take a look at it and give you some ideas.

Do you make some maintenance to your machine every now and then? if not, you should do it, start by deleting the temp files, press Windows + R then write %temp% hit enter and delete all the files in that folder, there’s a free software called Malwarebytes, it can detect malware that other antivirus can´t. And finally, share a file as you were told to check if it can be optimized.

Can you list the specs of your laptop? The other commenters are almost certainly correct that your machine probably just needs some TLC to the operating system. It’s likely gunked up with unnecessary junk. Most laptops come factory installed with all kinds of useless stuff.

I modeled and rendered my project on a hilariously underpowered laptop for the past year or more – and I mean ridiculously underpowered, an older Celeron mobile processor and 4GB RAM, Intel integrated graphics using shared memory, plus a clunky non SSD hard drive – and while irritating the job got done without problems other than the extended time everything took. Your nice shiny expensive machine ought to do great. Clean it out and you’ll be golden.

The problem might not be yours per se , it may be that she has unintentionally created a model with problems

If it is running that bad and you are working with interiors then 9/10 times it is because there is some insane complex plant or curtain that is destroying performance.
There are extensions to help point you towards these (CG impact report, Goldilocks) but often you can spot them a mile off if you simply switch to wireframe view in SketchUp - complex models will have so many lines they will be black clumps of detail in an otherwise sparse collection of wall geometry.

I see this a lot, teams of people working on projects and one can person make do with a model that runs abysmally and other team members struggle to work with it as their tolerance is much lower.

How can i share a file ? Sorry I’m new here🙋🏻‍♀️

If your file is smaller than 16 MB you can just drag it from your computer to your forum post. If it is larger you can upload it to a file transfer “cloud” service (Dropbox, WeTransfer, Google Drive etc…) share it there and post the link here.

That should not be a problem since sketchUp files are interchangeable from PC to Mac and vice versa.

Make sure that your PC is set to use the maximum power of your graphic card.

Try tu use as few as possible profiles, shadows and complex textures, for example to avoid taxing your graphic processor.

You can try a test as follow:

  • set shadows to off;

  • edit your style and set the profiles to off;

  • use monochrome rendering mode.

  • create a new scene (you can rename this scene Work or anything that suits you;

  • then set the previous parameters as you want them;

  • create another scene that you can rename Render or whatever suits you.

After that, click on the Work scene tab to set SketchUp in light rendering mode before using Zoom, Pan Orbit, etc.

When done with adjusting the picture, click on the Render Scene tab to get the nice picture that you want.

When creating the two scenes, make sure that you uncheck the Camera Position parameter if you dont want to loose a carefully adjusted position, orientation and zoom.

2 Likes

What are the file sizes the designer is sending you? have the models been cleaned up and is your workflow optimized (as pointed out by others above)

Are your drivers uptodate?

My money is on heavy models with everything turned on.

2 Likes

I’ll double down on that wager.

dont know the specs but my wild guess is that your laptop can handle the skp file as well as the mac can handle. The file might be corrupted somewhere. I’ve already worked some insane files with far worse laptop.
My 2 cents: clean your system, dont watch p*rn on your work device, create brand new file and import things little by little to the new file. Be aware of models created by others, especially models from random internet websites or from the furniture/lighting manufactures. I always make a new file for them, open them there and inspect them throughoutly.