My model has completely disappeared?!

Hi everyone. I am a relatively new user of SketchUpPro (about 6 months). My model has completely disappeared, along with the axis lines, after loading a component. I have reviewed other threads about this but cannot seem to use any of the advice given to resolve my problem. I have loaded the model to the warehouse, called “Rafih base”. If anyone can help, it would be much appreciated!

It’s kind of a mess.
Screenshot - 8_29_2020 , 1_06_33 PM

What was the component you added?

Will this work for you?
Rafih Base.skp (2.0 MB)

1 Like

I believe it was a pine tree; I have been at this for awhile so I cannot remember for sure, but I think the search term I used was, “pinus”

I didn’t see a pine tree but I got rid of the group that was causing the main problem.

1 Like

I didn’t see it actually successfully load…it seemed to go off into neverland. I had hidden construction specs under the model I was building…

Do you mean this thing on the left?

Yes, that works. Thanks so much! I tried searching online for an hour trying to find the answer but nothing worked for me.

yes, that’s it. Thank you!

There were a whole bunch of tags added to the model but most were turned off. I turned them all on, turned on Hidden Geometry and Hidden Entities. Then zoomed in a little bit (actually importing it from the 3D Warehouse made it easier because the camera was in close to the model. Then I deleted all that garbage with the text and the weird U-shaped things before hitting Purge Unused to get rid of all the unused stuff.

1 Like

There are various problems with this model. @DaveR seems to have gotten you sorted, but I’ll discuss the issues in more detail so that you can avoid similar in the future.

The problems are mainly in the Component named “Pergola - Wind Screen”. There are two instances of this component nested inside an unnamed Group, which makes it harder to find them in the Outliner unless you expand all and scroll around looking for them. I renamed the Group “Pergolas” to make this easier.

The “Pergola - Wind Screen” Component contains 760 (!) leader text objects that have lost their anchor and flown off to infinity. This is most likely the result of a bug that was present in versions of SketchUp prior to 2019. It was triggered when you attached leader text to a mainly 2D drawing and then edited the drawing in a way that erased the object to which the text was anchored. In your model they all said either “Chambre” or “Walk-in”, which might give you a clue where they came from. At this point these texts are all junk - their original anchors cannot be recovered and they don’t say distinctive things. So I erased them. Then I reset the camera so that the model was visible. I do these things via unpublished Ruby. sWilliams shared a short script that does the equivalent, though I think he tries to preserve the text content, which in this case will make quite a mess because there are so many.

Another issue with this component is that its contents seem to be randomly scattered over a large area compared to the main content of the model. Here are screen shots of the two instances in the Group showing their bounding boxes. The little smudge in the middle is the main content of your model.

I don’t know what this Component is supposed to be. Here’s a sample of its contents after turning on all but the tags that show only notation.

There are also a lot of these things scattered around

There are various things locked and hidden among the contents. That makes them hard to work with.

Unless you have some reason why these things need to be as they are, I’d suggest erasing that Group and purging this Component from the model.

Finally, the model isn’t using tags appropriately. Many of the Groups or Components have edges and faces that use tags other than untagged (formerly Layer0).

After doing all those things, here’s what I ended up with.

Rafih base.skp (2.1 MB)

1 Like

Thank you for all this information. I am still a very new user of this program. The components you refer to are ones that I downloaded from the warehouse. I am really not sure what I should be looking for in terms of problems when I use the warehouse. I did notice that the bounding box for that pergola was huge and didn’t understand why. All of the other things randomly scattered? I have no idea what that is nor why there were a bunch of directional arrows in the model. So strange.

That’s why the advice from experts is to never download from the 3DWarehouse directly into your model. Instead, download the skp file and open it in a separate, empty model. Then inspect the contents to see what you got. Unfortunately, the 3DWarehouse is not quality-controlled, and along with a lot of good stuff it contains models that have severe issues of this sort.

Edit: Out of curiosity, I searched the 3dWarehouse for Pergola - Wind Screen. All of the issues are already present in this model but hidden in one way or another. All you see is this:

but the time bombs are lurking invisibly to cause problems when you use this in your model!


Thanks! I did not know about downloading from warehouse into a separate file…will do so for now on!

By the way, if you really wanted the visible part of that file, here it is:

pergola-wind screen.skp (197.0 KB)

1 Like

This topic was automatically closed after 186 days. New replies are no longer allowed.