My Extensions - Pink highlighted in Warehouse.!


#1

To all,

I’ve notice a few of my extension are now highlighted in ‘PINK’ on my extension warehouse.!!!
These ones I can’t Update, Disable or Uninstall from this interface, so have to do this the long way.

Is there something my end I should do to correct this or is it SU HQ related.
Anyone else have this glitch…?

Over & out,
Clayton

(see attachment)


#2

@Bryceosaurus, @ChrisFullmer - heard of this one before?


#3

Yeah, I might have an idea or two on this. First, the pink color just means it is outdated. The fact that nothing is working from the EW page is a bug in the EW. You will probably have to remove the plugin manually. Try this process on one of them. If it works, do it for the others as well.

(I think you’ve tried this part, but I’ll put it here in case it helps anyone else in the future who reads this)
Click uninstall. See if that uninstalls the plugin. If not, try disabling it. Then restart SU and then try to uninstall.

If you are unable to uninstall it from the webpage, then you might can try to do it manually. First, close SkethUp. On Win, browse to

C:\Users<username>\AppData\Roaming\SketchUp\SketchUp 2014\SketchUp\Plugins
(warning, the folder AppData is hidden. You will need to make hidden folders be visible in your windows file explorer to see it).

Remove the file and folder for one of the plugins. Now start SketchUp and go to the EW. Hopefully the plugin you removed is no longer listed as installed, but should be listed with the other uninstalled plugins.

If you are able to get i uninstalled, there should be the option to “Remove” it from your list. Once you can remove it, click on the remove button. Then waiy for the screen to refresh (might take 10 seconds). If it is still on your list, with a ‘Remove’ option, click remove again. Click remove as many times as needed. Eventually it will be removed from your list (hopefully after just two or three “Removes”).

After that, you should be able to reinstall it. You will get the most current version, and it should no longer be pink.

I hope that helps. We are working on a fix for this issue. Ideally we would like to make it easier and easier to manage and use plugins without ever having to navigate to your plugins folder.

Let me know if that helps or not. Thanks!

Chris


#4

Hi Clayton

Would you do me a favor and try updating again today? I was having issues yesterday as well. However now they seem to be working.

Cheers!
~Bryce