Most of my options are grayed out when I right-click

It looks like he re edited his post TIG instead of just answering and being normal lol, becuase I didn’t read that at all otherwise if I did I wouldn’t be asking again about it :+1:. Either way whether he re edited or not though regardless, my Fredo plugins have been updated for awhile now so I’ll go back in and check again though and if something happens I’ll leave a comment. Thanks

None of my posts were edited after the fact.

Well looks like I miss read :+1:. I believe the Fredo update was the problem as you mentioned, looks like fredo just made an update recently (as in a week ago) and I beleive updating to that version solved the problem for me as I’m not experiencing this anymore.

For users experiencing this problem, some options in my right click sketchup menu would gray out after spending about half an hour in a sketchup model. So if anyone is wondering the updating of Lib Fredo solved my grayed out native sketchup functions issue, specifically things like explode, make unique, etc were grayed out for me until I updated everything within my libfredo extensions.

Btw and for future users, the page should be updated to show that the solution was not the DaveR original solution and in fact the one that he talks about updating the fredo extension.


1 Like

Fredo fixed this problem back in November of last year. He released LibFredo6 v9.4b to fix it. Since that release he has released 20 more updates to LibFredo6 as of 1 June, 2020. some for bug fixes and some to support changes to existing tools or to support new extensions.

Hi all.
Is this issue solved?
I have the same problem and am running the latest su pro 2021 21.1.299 64-bit…
It happens after 30min or so (unless it is related to the number of undo operations I do?)
I need to save the file in the actual state, close SU and reopen the file to get the right click options to get ungreyed and accessible again… Soooo annoying. 2021 has so many bugs…


Please see Intersect Faces and other Menu Items Greyed Out - #51 by jwhida instead of posting on this thread, to keep it all in one place.

I have the same problem with this version :face_with_symbols_over_mouth:

Fredo has determined that this problem is not with any plugins and in fact sketchup, I would agree after doing some tests and discussing this with him. I’ve messaged sketchup, hopefully this gets resolved.

We know. See two posts above yours.


Ok cool, thanks!

This issue is happening for me ALL THE TIME during modelling sessions.

1 Like

As has been mentioned in this thread already, the developers are working on a solution. It should be sorted soon.

I have heard this response now ever since I paid a not insubstantial sum to purchase a year-long licence. This is getting a bit rich. I have no doubt the developers can fix this without much trouble if given the budget to do so.
I stress, I love the program and will do whatever I can to support the company’s effirts to develop it through to its full potential, and there is a lot of potential here with AI. However, the company must realise that this is starting to skirt the requirements of consumer law as defined by statute and likely common law in many if not most jurisdictions (well the common law part only in US, Canada, Australia, NZ, UK, India) but all have similar statutes re consumer law as Europeans utilising Napoleonic law.
I stress, this is certainly no threat, but it only takes someone with enough time to raise this and create a mess. To paraphrase most common law statutes the product must perform to a reasonable standard or either be replaced or the consumer reimbursed in some way to ensure financial equity on their purchase . Normally in this context equity would be secured by such means as extending the subscription for the time this critical issue was not resolved during their subscription, but not necessarily by refunding the subscription like is applicable to most other purchases, which is why this situation can create a mess. It more complicated (compared to just resolving it) by virtue of the time invested in the program by users and the ultimate cost that represents to them in the commercial context. This means a simple - we’ll pay you your money back - is not a result which would restore equity in the purchase.
The problem of in context menus is a critical feature. You cannot have a context menu go grey and have to restart the program every 30 minutes and consider that a minor bug which is the norm for most pieces of software and for which the law allows. This situation is not helped by the repeated promises on these forums that Trimble’s developers are fixing the issue statements made over an inordinately long time. Please also bear in mind the legal issue I have outlined above is not covered by contract law anymore. For the sake of avoiding resources being wasted in legal issues when we would rather see those resources go into further development of a product with so much potential please fix these issues before someone takes a shot at you - and it won’t be me. But its not worth the risk of someone getting that cranky and having the money and time to take the free kick.
All Trimble has to do is to fix this issue. Please do so and maintain the loyal followers of a very useful, niche product. At present it sometimes comes across as Sketchup users whom pay for the subscription are taken advantage of. Please copy any reply to my email address as well as posting it on here. I await your response.
Michael Shea

Perhaps spending less time writing pseudo legalese and more time reading you might notice that an update has been released that fixes the issue.


Might keep a copy of the released installer, I save mine in Trimble Connect.

Fantastic mate. I’m not offended by your comment re my pseudo legalese as am not a lawyer and wasn’t pretending to be one. The points I made are relevant due to experience with another case - again not driven by me. Just happened to be an engineer stuck in the middle to estimate cost. Vut thankyou for alerting me. But do understand this update only occurred, what, 3 days ago, and look at how long people have been asking for it to be fixed. I was just writing in a quest for fairness, but yes, should well be doing something else on a Friday night
In any case, thankyou! for your alert re the update, It is genuinely appreciated, as is your contribution shown by your profile.


Thanks for the positive feedback box! Cheers

Just installed the update 2021.1.2, and I’m very satisfied with the new stamp copy mode instead of the sticky key. Also, thanks for the fix of the grayed-out options. Those two problems were REALLY messing with my workflow all summer. Thanks, SketchUp team to listen to us. It’s a good feeling. :slightly_smiling_face:

Why didn’t you install the current version; 21.1.332?

The update is labelled 2021.1.2 to me, but also true to say it’s 21.1.322.