Model worked for a week and now constantly crashes

I have been working on a floor plan model for over a week. Just today, when I tried to push/pull to cut an opening for a door it crashed. Now, ever since, it just keeps crashing. I may be able to “cut” a door or 3 before it crashes again. It’s very sporadic. I have done the Window/Model Info and purged unused and fixed problems - no problems to report. I try again and crash. It has started to happen by simply trying to move an object (rectangle on a face) and it’s crashing. I have copied the geometry out of the file and pasted it into a new one…worked for about 10 minutes and started crashing again.

Any thoughts? Please, I need to get this model done for Friday.

What version of SketchUp are you using? What operating system? What graphics card? Please complete/correct your profile. “Applications Engineer” is not a graphics card model.

Share the .skp file with us so we can see what you have going on.

20.0.373
Windows 10 Enterprise
Invidia Quadro P500

Elementary School New.skp (1.9 MB)

Check with Nvidia to see if your graphics drivers are up to date. Update them if they aren’t.

I’m not having any problem with cutting doors through the walls in your model. I have deleted the faces hiding the image below instead of using X-ray.

door

Thanks. I can get through a few, then all of a sudden it starts to lockup. I’ll try the drivers. Come to think of it, I think IT pushed a windows update last Friday. I’ll let you know.

It’s fairly common for Windows updates to include broken graphics drivers. Make sure your Nvidia card is being used for SketchUp. Windows updates also sometimes change the default to the integrated GPU, too.

Have you tried to cut about 10 doors yet? I upgraded driver twice, rebooted twice, it cuts about 3-4 doors then just closes. I’ve been doing it with transparency for years, so I struggle with that being the problem… If that is the issue, how do you get the floors back in easily?

Did it without using xray mode and it still crashed. I was able to “cut” in 4 doors before it just closes down. Think it’s a windows thing and I need to update to a newer version of Sketchup now?

I cut a bunch of doors with no problem. I didn’t keep track but at least 10.

So it did work and now it doesn’t. SketchUp 2020 hasn’t changed for more than 6 months so what did change on your computer?

You could trace an edge and restore it. I guess if I were modeling this building I would make the floor slab as a separate group or component anyway.

I don’t know why it’s crashing for you but bad graphics drivers are a common problem. They are something that Windows updates frequently break. I can’t say that it’s not crashing for me because I’m using 2021 but 2021.1 tends to be a bit more robust. I suspect it’s different graphics card/drivers.

When SketchUp crashes do you get a Bug Splat? If so, are you sending the report in with something that identifies it came from you?

No bugsplat. SU just closes

Maybe @colin has a siggestion. What did you find regarding the drivers from Nvidia?

I upgraded drivers using Device manager… Still the same issue. I then went directly to Nvidia and found the latest drivers…seemed to be dated 6/2021. Installed those and rebooted again…still same issue with Sketchup.

I did find some garbage that could be getting in the way and might be causing you problems.

Notice the profile edges where there shouldn’t be profile edges. These are rooms 705 and 707.

Was SketchUp installed by right clicking on the downloaded installer and clicking Run as administrator?

Does this one behave any better for you?

Elementary School New.skp (1.8 MB)

It was installed over year ago and has done 10+ projects in that time. I honestly can’t remember. I will try… Thank you.

I will have to let you now in the AM…

A couple of comments on your model which may not relate to your issue at all.
Most dimensions in your model are showing a tilde which means they are approximate. This should be fixed by changing the Display Precision to 1/64th but it doesn’t. This is most likely due to you working with Edge Snapping turned on and set to 1/16th, this is a know way to introduce tiny inaccuracies into your model. It may not be effecting you at the moment but it can lead to shattered models.
You would do well to look into the use of groups, components and tags. Having this much raw geometry all joined together is a recipe for disaster too. Not to mention you could cut down the amount of modelling you need to do by using components for a lot of your structure.

1 Like

Length Snapping would be easier to find and turn off (Window>Model Info>Units)

1 Like

Thanks for the tips Box. I have been having an issue in some models where walls get funny. The first video I saw about making floor plans was to use rectangles and do an offset to make the outside wall. Then just keep using rectangles to make rooms and then offsets. It seems like I get some rather odd things, especially when the wall isn’t true North/south, but rather angles.

Can you provide some more info on the 1/64th thing you’re referencing above? Where to find and adjust…I only care about accuracy to the nearest foot or so…I do all walls to 9’ and doors to 7’.

@DaveR It does seem to be working better. Thanks!!! I was able to get the last few doors done so I can render out the views…

Have any tips on how to better do floor plans?