Mobile App on iPad crashes with iTunes transferred model

crash

#1

I have this app on my iPad Air on iOS 9.

I can open the sample model.
I can open a model downloaded from 3D warehouse.

But when I start the app after transfer a model from iTunes, the file is shown in the app with no preview (only the sketchup logo), and a rotating arrow appear on the bottom right corner, just rotating there. After it rotates for one or two seconds, the app crashes.

Now I try to open the app again. ANOTHER FILE appears! The new file seems to be a copy of the previous file. The previous file is still there, with no preview, with the bottom right icon NOT rotating. But the icon of the new appeared file is rotating. And, after 1 or 2 seconds, the app crashes.

If I repeat launching the app, more files appear.

Now I go back to iTunes, there’s only one file. I delete the file within iTunes on my Mac. Now I launch the app on my iPad again, it does not crash. But there are several cloned files there. I tap the ‘i’ button and find out that the file size is 0kb. I can delete the files.

So, what is the problem and can you fix it?

I have tried turn on and off my iPad, and I have tried uninstall and reinstall the app.

This issue did not exist in an old version of the app, I don’t remember which version. But after an update, it appears, and the following updates do not fix this.


#2

I am the only one have this issue?