Misc. Operator problems using SketchUp 2016

pro
operator_error

#1

Problems with functionality.

There are numerous problems. Just the ones I can think of now.

  1. When I try to designate U for unhide in Shortcuts, it doesn’t update and the
    U does not work to unhide.
  2. the Layers feature is not working. I add Layers (+). It lists them, but will not hide them
  3. my send to Layout function is greyed out and not functional

#2

[details=If you are running on MS Windows, … (click to see more)]If you are running on MS Windows, did you install by right-licking the installer, and choosing “Run as administrator” ?

If, not, do it again, and choose “Repair”.[/details]


Please fill out the 3 IT questions in your forum profile.


#3

[details=If you are running on MS Windows, … (click to see more)]Did you click the + button after entering the U in the add box ?

(After the + button is clicked, the U character will be moved to the Assigned list below the add box. This allows you to successively add multiple shortcuts for the same command.)


SketchUp User Guide: Creating keyboard shortcuts says:

4. In the Add Shortcut text box, type the keyboard shortcut that you want to assign to the command and click the + button. The shortcut you type moves to the Assigned box. If the shortcut you chose is already assigned to another command, SketchUp asks whether you want to reassign the shortcut to the command you selected in Step 3.[/details]


#4

Layers are hidden by unchecking them in the Layer Manager.
But you cannot hide the active layer. So, make sure the radio button (pip) is set on “Layer0”.

Other than this guess, I don’t know what you mean by “It lists them, but will not hide them.”


#5

LayOut is a Pro license only application.

If you were running a Make install under a trial, and the trial expired, then your install would have reverted to the Make edition, and all Pro features will be greyed out or no longer work. (Sometimes a “Sorry, this a Pro feature” popup will appear if the menu items are not greyed out.)


#6

U works fine on my mac, but there is the age old issue of Enter/Return not working…

so, enter your key and click outside of the input box for it to stick…

add a file where layers aren’t working for vest advice…

john


#7

Running Mac OS


#8

I am on a Mac. There is no plus button.


#9

It will help us to help you if you provide some more information.

  • Please take a moment to fill in the Graphic Card, Operating System, and Sketchup Version info in your forum profile preferences. That way we won’t have to guess what you are using (or search your previous posts as I did) and won’t give you Windows-specific answers when you are on a Mac.
  • Like @john_drivenupthewall, I have no trouble setting U as a shortcut. In fact, I currently have it bound to pageUpdate and it works fine. I suspect he may be right that you are getting caught by the oft-lamented “enter does not leave the entry field” issue of SketchUp on Mac. We Mac users have to retrain our muscle memory to avoid this quirk and still get caught by it on occasion.
  • What precisely do you do to attempt to hide layers? In the Layers Window, you should be able to click these boxes to control layer visibility. If you are looking at the Toolbar, it does not offer this ability.

  • Has your Pro trial period for Make expired? If so, you can’t use Layout. What version of Mac OS are you using? There can be issues with the new “path randomization” security feature of Gatekeeper that make Pro users unable to launch Layout from within SketchUp.

#10

Figured out why Layers wasn’t working. Forgot to link to Entity Info


#11

For the sake of others who might run into the same issue, please clarify what you mean by this. I for one don’t know how to link to Entity Info or why it would cause problems.

If the Layers Window is open (which is independent of Entity Info Window) can’t you set Layer visibility? Or do you mean that you were looking at the Layers list in the Entity Info Window instead of in the Layers Window? That list, like the Toolbar, doesn’t offer visibility or color options, it only lets you pick a layer to assign to the selected Entity or Entities.


#12

Meaning, for the ability to shut layers on and off in Layers, you must open Entity Info and designate that
layer in the Entity Info box. Then the visible and not visible button works in Layers


#13

I think we have some miscommunication happening here. Do I guess correctly that English is not your first language?

The visibility on/off checkboxes in the Layers Window are always “live”. They can be changed at any time, regardless of what you have or have not done in Entity Info - with the sole exception that you can’t hide the current “active” layer. But a layer’s visibility setting affects only those Entities that are associated with that layer

You set or change the layer association of a selected Entity (or set of selected Entities) using the Entity Info Window.

So, in that sense I suppose one could say they are “linked” in that you have to assign a layer using Entity Info before the layer can affect the visibility of an Entity. Sorry, but that’s like saying “I have to paint my car red before it looks red”.

By the way, it sounds like you need to read up on SketchUp’s layers to avoid getting into very confusing situations later. They are not at all the same as 2D drawing layers or Photoshop layers, and thinking of them that way will lead you to problems. Suggested reading:

https://help.sketchup.com/en/article/3000122


#14

This topic was automatically closed after 91 days. New replies are no longer allowed.