Microsoft Train Simulator Plug in issues


#1

I am new to Sketchup and in order for me to be able to use it, I need to be able to export files into Microsoft Train Simulator. There is a plug in written for it that worked great in version 8 but, now is having issues. Can someone look at this and see if it can be fixed or maybe it is just me.

http://www.rail3d.info/tools/sketchup.aspx

Here is a youtube video that shows how the plugin is supposed to work. It’s in Czech but, using an english Sketchup. Start the video around 7:03 mark.

He is also using a rendering on how far the object can be seen. Is that a different plugin?I would appreciate any help to get this to work. Maybe someone can update the code to make it work in the newer versions.


#2

Hi Rudy,

The download page for the Rail3D plugin states it has been … "Revised for SketchUp Make 2015"
Unfortunately, due to the way the plugin files are organized, one would have to install them manually.

I ‘repackaged’ the plugin files as an .rbz and it installed in SU 2017 without issue.
SU_2_Rail3D.rbz (4.4 KB)


Here’s an .STK file exported via the plugin from SU 2017.
(Zipped because the forum doesn’t support .stk files)
Simple House SU2Rail3D Test.zip (660 Bytes)


Here’s the SU 2017 model file from which the .STK file was exported.
Simple House Test Model.skp (30.8 KB)


#3

Wow you guys do work fast on here. So, I take those 3 files and put them in my plugin folder Myapp data…?


#4

No. You take the file with the .rbz extension, put it anywhere you like (your Downloads folder, for instance), and, in Sketchup 2017, open the Extensions manager and add it from there.

Anssi


#5

No … !


Here’s how how to install .rbz plugins in SU 2017.

  1. In SketchUp, select Window > Extension Manager. The Extension Manager window appears.
  2. Click the Install Extension button.
  3. In the Open dialog box that appears, navigate to the .rbz file saved to your computer, select the file, and click OK (Microsoft Windows) or Open (Mac OS X).
  4. When SketchUp warns you about installing only extensions from trusted sources, click Yes to proceed and install your extension. (This assumes you do, in fact, trust the source of your extension.)

#6

You guys are really a great community. So I understand the rbz file but, do I need the .rb and rd files? These where in the oreginal package.

Thank you so much

Rudy


#7

What I ment was that the download, had 3 files. one separate and two in the at folder. Did the new .rbz take care of that? Is that now the only file I need?

Rudy


#8

The RBZ is really a ZIP archive. You do not need to unzip it, just do as Geo explained and SketchUp will unzip it and copy the files where they need to go.

After All the button is captioned “Install Extension…”


#9

All the necessary plugin files and folders are within the .rbz file I shared in my 1st reply.
The files and folders within in the ‘original package’ were not organized properly.
Simply install the .rbz plugin as described in my 2nd post.


#10

The plug in installed fine but, fails to create the .s file. It is also missing the functionality that is in the video. The video shows an option to show how far the object can be seen. This is around the 7 minute mark. I tried to save it as an .s file like the video shows and when I tried to display it in Sview program, it said invalid format.


#11

I don’t understand your mention of a .s file extension

The readme.txt file that came along with the plugin states … Sketchup Export to Rail3d STK


#12

https://fileinfo.com/extension/s says:

.S File Association 2

Shape file used by Microsoft Train Simulator, a program that allows users to play the role of a locomotive engineer or passenger; contains shape data such as geometry, images, size, texture, and lighting effects; used for customizing and displaying locomotives in Train Simulator.

I seem to remember MS Flight SImulator also using .s shape files.


#13

I haven’t a clue as to why the plugin exports an .stk file when MSTS requires an .s file

Have you tried contacting the plugin author, Mark Goodspeed?
I notice he has an email address posted here:
http://www.rail3d.info/wiki/home.aspx


#14

The part that is not showining up from the video is here The options for LOD as missing.


#15

In this screen capture you can see that he is saving the file in .s format. To check this I can download sview2…mine says invalid


#16

Ok I found one more plug in that is supposed to do this too…Maybe it is the one from the video. I am not sure how to make this work in sketchup 8 as well as sketchup 15 or 17.su2ts20 sketchup plug in.zip (23.9 KB)


#17

It appears to work in SU 2017.
Change the file extension from su2ts20 sketchup plug in.zip … to … su2ts20 sketchup plug in.rbz
Then install the .rbz plugin as described in my 2nd post.

Edit
It seems the .htm Help file included with the plugin can’t be reached via the plugin’s menu within SU.

Here’s just the Help file:
su2ts20 sketchup plug in_Help.zip (2.5 KB)


#18

This topic was automatically closed after 91 days. New replies are no longer allowed.