Menu window too small for Camera>Edit Match Photo


#1

Hi! Yesterday Camera>Edit Match Photo worked. Today the Match Photo menu is truncated vertically. I’ve exited without saving and reloaded but the app works the same. Any ideas?? I’m using Sketchup/Make 2015 on Windows7 64.


#2

Did you try re-sizing the dialog back to the size you like by tugging on an edge?


#3

Thanks for the response, catamountain. Yes I tried that. Sorry that I didn’t make that clear. I could only pull down to expose 1/2 of the first line of the menu choices.


#4

Try Window > Preferences > Workspace > Reset workspace?


#5

That didn’t work. Also, in the match photo window, the gear icon is greyed out; the + icon is selectable.


#6

You will not get an active gear button until first adding (+ing) an image.

Can you add a screen shot of the dialog?


#7

I created a new file and used Camera>Match New Photo etc… Same result. See attach


#8

R-click on the top blue title bar of the dialog window. The Restore option may be useful. I see a grayed out Size option in the list at my end. I don’t know it that control can be activated.


#9

Dude, you’ve done it. Thanks! For my benefit could you elaborate on the “grayed out Size option in the list at my end”? I think you’re saying that the window for Match Photo is greyed out but I’m not sure what the list is. Is it the list of options within the Match Photo window?


#10

I was referring to the same context menu you see when r-clicking on the title bar. The dialogs are webdialogs with the typical browser controls provided by your OS browser, IE. Developers who rely on such tools pick and choose what all is added to the dialog window. The Size option I see may be default for such a context menu, but the control may not be used, so it is grayed out.


#11

@DanRathbun, shouldn’t the Reset Workspace option in Preference have restored the Match Photo dialog?


#12

The Match Photo dialog behaves a little odd it seems.


#13

Actually on MS Windows, this is a sticky toolwindow MFC class, not a webdialog window.

As Geo points out it has two expansion states (and should have had one of those little expand buttons in the top right corner (like the Components and Styles inspectors have.)

You can expand it totally by clicking the caption bar, or incrementally, by clicking the lower border. Click border once to expand to the compressed state. Then double-click the border to fully expand it.

(Some of this behavior may be due to Microsoft Foundation Classes base window object behavior being inherited, rather than being explicitly programmed by the SketchUp development team.)

We would hope so. But as I cannot see the C code, this would be a better question for @bugra or @tt_su .