Maximum physical size of a SketchUp model

Here’s a useless SketchUp fact:

SketchUp stores coordinates as double, and in inches.
Therefor, the maximum physical size of a SketchUp model is 1.7e308 inches, or about 4.3e306 meters.
Considering the observable universe is about 4.4e26 meters, a SketchUp model can be about 1e12 (or 1,000,000,000,000) times bigger than the observable universe.

(Unless my math is wrong)

Note that at this scale, the minimum precision of the model can only be one inch.


john [not jbacus]

All of which begs the question “why does SketchUp start to have issues with models considerably smaller than the claimed range?”. For example, on a model of an entire city one starts to encounter problems selecting and placing human-size things in the view, as if SketchUp can’t resolve the difference in coordinates of the points. We frequently have to advise people on how to deal with models imported from other apps (notably CAD) that merrily place objects too far from the origin for SketchUp to handle. I have long suspected (without technical proof) that something in the way coordinates are passed between the CPU and the OpenGL graphics GPU causes this effect.

1 Like

@john_drivenupthewall So my math WAS wrong!

1 Like

Just for fun, I created a cube that is nearly 85 million light years on a side:

That’s a volume of 608,213,151,133,022,223,548,903.01542135 cubic light years :slight_smile:


Now try to place another one 1m x1m x1m near it but not on a vertex or edge :flushed:

1 Like

Ironically, if I started with a 1"x1"x1" un-grouped cube and resized the model setting the length of one edge to 1,000,000,000,000,000,000", I was still able to navigate the model and add/edit geometry with no problem.


1 Like

I wonder how navigable that model is. I understand that the limitations imposed by OpenGL are significantly lower. BIM application vendors recommend that your model should keep somewhere within about 30 kilometers from the origin (both Archicad that uses OpenGL and Revit that uses DirectX).