Mac window jumps around

So I have two sketchup files open for this “HOW TO CLASS”… in one of them, file “B”, I am using the tape measure to take measurements off of (or trying to), and the other file I am building the same thing, from the downloaded file for the class. I am not having any trouble working on file “A”. But, when I need a measurement from file “B” I can switch to that window and have full control, zoom, pan, and orbit, but when I click on a tool and it snaps to a point… It jumps right back to the window with file “A” and it is supper annoying…

Any thoughts?

Running SU on my mac with the latest version…

I am trying to make sense of what you have said in text. (maybe image would be helpful)

If I had understood correctly, it sounds like you have one of the toolbar floating around and clicking on it is putting you back to the “active” window of the file.

Instead of using floating toolbar, customizing the toolbar on the top of your sketchup window and using that would be more intuitive since it will prevent it going back to the “active” window. Or simpler method would be to use shortcuts. it is “T” for tape measure btw.

I am not having any issues with the tool bars… I can select any tool that I want. Once I have a tool selected, hover over the drawing and it snaps to a point, the window jumps to the other window with file “A”.

I’m also not totally sure I understand your description, but it sounds similar to the issue several people have reported when using multiple monitors or multiple virtual desktops (“spaces”) in Mac OS X. SketchUp seems to get confused about which space the model view should go on, especially if you open SU on a different space than the one where it last closed and especially if it crashed. I have only a single monitor but run three desktops and this was happening to me. Choosing “assign to this desktop” from the dock options menu fixed it for me, though some other people have reported that didn’t work for them. It’s easy to try and see if it helps.

I can try it… But I am not sure where I choose “assign to this desktop” is located…

Maybe this will help a little…

With SketchUp in the dock, right-click the icon and choose options. If it isn’t in the dock, you may need to put it there to be able to access this option. Also, this option won’t appear unless you have multiple screens or spaces.

Yes, that video appears to show the phenomenon I wrote about. After you switch to the second space, SketchUp determinedly jumps back to the first one.

Edit: I strongly suspect this is related to how SketchUp manages its OpenGL view window, as I have never had it happen with any other app. Also, I previously reported a bug in which a Tool activated in one model view window would affect the view in all visible view windows despite targeting only the current active model and its view.

SU is in my dock, when I select it, then right click, the option menu has a check next to “keep in dock”. I tried to toggle it on and off, still no luck. :frowning:

Hmm…this is what I see:

Heres what I see

It’s also worth looking at the system preferences for Mission Control. Here’s how mine are set. I think unchecking the “Automatically rearrange” one is crucial, as when it is active the desktops get dynamically renumbered based on what you used last (so assignment to a specific one becomes meaningless).

Mine looks just like that…

Rats! Well, since Trimble has never officially acknowledged this problem or proposed a solution, I’m out of ideas. Sorry!

Thats a bummer and makes things difficult… Thanks for the help and suggestions!


I found another reference that says this option is captured in


You can delete this plist to reset the spaces preferences, then you must either log off and back on or use Terminal to issue the command

killall cfprefsd

These last steps are necessary because OS X caches the preferences and if you don’t force it to rebuild its cache it will just regenerate the plist from cache!

I have 3 files that are similar… Delete just the one you listed or all 3?

From what I read, all three.

Doesn’t seem to help any :frowning: