Mac trial download

I have downloaded sketchup to my Mac.
The install file was placed in my download folder.

The issue is that the sketchupmake-en.dmg has an additional file
extension .download

I have tried clicking on the file but nothing happens. And I tried to edit the file
name by removing the .download. But that does not help.

Can someone please offer ideas on how to deal with this?

A .download file is created when the download process is interrupted before it completes. Because it isn’t complete, it won’t work to install SketchUp. Try downloading again, and wait until you see only the .dmg extension.

Hi, thanks for the quick answer.
However, I have a dmg extension but when clicking on it a textile appears.


Is your plan to download and use SketchUp Make 2017, or download and try the SketchUp 2021 version?

If you want Make, this is the right link:

Mac Make 2017

If you want to try SketchUp 2021, this is the right link:

Mac SketchUp 2021

Neither of them have the file name you gave. Whichever one you do get, double-click on the DMG file, then in the window that appears you drag the SketchUp folder on to the Applications alias, to set the folder copying across from the disk image to your drive.

After copying, eject the disk image file, then go into Applications, SketchUp 2017 or 2021, and open SketchUp from inside that folder.

Thanks, it looks to work right now !!