Loading old files into SketchUp 2019

I recently downloaded SU 2019 and have been trying to open my older files from 2018 & 2017 but they open as a blank file. Am I missing a setting somewhere to load these older files?

Most likely the problem is your graphics card. In SketchUp, go to window>Preferences>OpenGL. Untick Use Fast Feedback. Does that help?

Bingo, Thank you

The fact that unticking Use Fast Feedback works indicates your graphics card and it’s drivers aren’t really up to the job.It’s well known that Intel integrated graphics aren’t very well suited for 3D modeling. Keep an eye on it.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.