Load error popup


#1

I’ve been using Sketchup Make for a few weeks and I have a problem: I can’t remove Load Errors pop-up (present since I unsuccessfully tried to download an extension)

I don’t seem to understand the answers to this problem in the community posts
(I’ve uninstalled and reinstalled su 2016 make 32 Bit/Windows7> and run as administrator but it doesn’t solve the problem).

Here is a copy of the contents of the popup:

Error Loading File C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/core.rb
Error: #<IOError: Staging directory not found>
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/c_extension_manager.rb:101:in prepare_path' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/core.rb:129:inmodule:Lib
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/core.rb:110:in <module:TT>' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/core.rb:20:in<top (required)>’
C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:inload’
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2.rb:40:in register_extension' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2.rb:40:inmodule:Lib
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2.rb:14:in <module:TT>' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2.rb:13:in<top (required)>’
Error Loading File C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/tt_solid_inspector/core.rb
Error: #<IOError: Staging directory not found>
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/c_extension_manager.rb:101:in prepare_path' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/core.rb:129:inmodule:Lib
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/core.rb:110:in <module:TT>' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/TT_Lib2/core.rb:20:in<top (required)>’
C:/Program Files/SketchUp/SketchUp 2016/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in require' C:/Program Files/SketchUp/SketchUp 2016/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:inrequire’
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/tt_solid_inspector/core.rb:10:in <top (required)>' C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:inrequire’
C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:in load' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/tt_solid_inspector.rb:41:inregister_extension’
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/tt_solid_inspector.rb:41:in <module:SolidInspector>' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/tt_solid_inspector.rb:15:inmodule:Plugins
C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/tt_solid_inspector.rb:14:in <module:TT>' C:/Users/ahc/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/tt_solid_inspector.rb:13:in<top (required)>’


#2

It looks to me as if you’ve failed to install the require TT_Lib2 files which are required by many of ThomThom’s extensions. Uninstalling and reinstalling SketchUp won’t ever fix that. Go to the Extensin Warehouse and install TT_Lib2.


#3

Sorry about my late reply. Thx for this

9vbgi


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.