Lines disorder aftr importing to sketchup


#1

hey guys
so im having a problem here after importing to sketchup from autocad
on the top view i can c that every thing is normal ; when i rotate i find that i got lines up nd others down so how cn i solve this problem
thank u …
p.s: i ll post the 2 files
before importing to sketch up do the next :

  • I opened your DWG in AutoCad
  • I selected all (ctrl-a) and then, with a shift+window from left to right deselected what was visible
  • then I pressed Delete.

then I selected all, again, and moved everything to the origin (using
the lower left corner of the “frame” polyline as a reference.

  • Then I exploded everything twice to convert the file down to lines, arcs and texts.

After saving I imported it into SketchUp, using Meters as the import unit (Options button on the Import File dialog)
placette2.dwg (79.4 KB)
problem model.skp (230.6 KB)


#2

It looks like your DWG file is isn’t made flat. This is a good example GIGO but it can be fixed. You could improve the DWG in AutoCAD or you can use an extension such as TIG’s Flatten to Plane to repair the imported lines in SketchUp.


#3

If you haven’t got a “flatten” plugin in your AutoCad or SketchUp, you can do it in SketchUp Pro:

  • select Top view and set your camera to use Parallel Projection
  • export the view to DWG to full scale(File menu>Export>2D Image…)
  • import the DWG you just created, perhaps to a new empty SketchUp document.

Anssi


#4

yes it works :smiley: THANK YOU