Lines disappearing as zoom in & out

Lines disappering as Zoom out
RH Hexagon Feb 28~.skp (206.0 KB)
Why are lines appearing & disappearing as I zoom in & out. I’ve been doing SketchUp for 6 months & have never seen this.

Peter Enns

https://help.sketchup.com/en/sketchup/clipping-and-missing-faces

Looks as though you have a case of the above.

I doubt it is clipping, it looks like a simple case of a face that is not planar or edges off axis. But since the model uploaded isn’t the one in the vid it is hard to give a full answer.

In these six months have you ever tried going through the:

?

As has been suggested by others before.

1 Like

@Peter-7 i am begging you, on behalf of the entire SketchUp Forum community… PLEASE take or re-take the Fundamentals class at learn.SketchUp.com!

Abandon this model you have been struggling over and start again AFTER you learn the basics!

4 Likes

It looks like those lines are not actually “on/in” in the surface and are partially behind it.
I guess you’ve got “back edges” enabled which is why you are seeing them when they are behind.

If you turn on “color by axis” it will be easier to see if that is the case

It looks like you made Components out of your beams and Grouped them. That’s good. But the beams are still a bit crooked:

Aaron, Thank you for your suggestion. I really appreciate your suggestion.
00_Co-Work_Template.skp (1.2 MB)


I had gone over them before. But, I only did the beginner level courses. I did not realize there were intermediate level courses there.

I’m taking your Commercial Interiors course.

I got to the point where I get to the double doors, measure them with the Tape Measure tool & key in 6’. I’ve done that type of measuring before. One thing is different today. That Resizing Active Group message does not show up. I tried several times.

What’s wrong? Do you think my preferences could be set up wrong?

Peter Enns

Without seeing your model I can only guess. My best guess would be that you are not actually in a group.

00_Co-Work_Template.skp (1.2 MB)
It's in a group
Hello Aaron, I right clicked to check it out. The file IS in a group.

I’ve attached the file if you want to check it out.

Thank you.

Peter Enns

Possibly you have to press Options or Alt key to toggle the between creating guides and measuring with the Tape Measure tool? Look at the lower left information bar to see which mode you are in. You’ll want the measurement mode (no Plus sign next to cursor).

I will suggest that it’s best to work with your floorplan flat on the ground, so that you have blue direction coming vertically up from your floor plan. Otherwise orbiting around your plan view becomes quirky.

Right… so are you editing the group, then trying to use Tape Measure (just verifying tnat it is in a group does not help, you have to edit it)? I just opened your model, double-clicked to enter the group and used Tape Measure to scale it without an issue.

Drafting Mar 1.skp (1.3 MB)
Converting to 6' Does Not Work
Aaron, I tried doing everything you said. That magic message still does not appear.

Peter Enns

Did you click both ends of the line and then type 6’ and hit return?

1 Like

Yep. It looks like, @Peter-7 , that you are missing the second mouse click. If you do not click to create the line then SketchUp does not know WHAT it should scale to 6’.

Hello Box, After reading your question, I tried doing what you suggested and was successful in getting box with the question about resizing. However, for the past hour I’ve been trying to replicate what I did and cannot.

Please expand upon what you said. As you were clicking each end, did you hold the shift key down? What was the point of clicking each end? Is it supposed to be blue before I hit Return? Etc.

Peter Enns

People get confused by this for some reason, I’ve never understood why.
There is no magic to it, you don’t need to use modifier keys or even hold you tongue the right way.
Double click to open the group for editing, activate the tape tool, if there is a little ±-- as part of the cursor tap ctrl/Command (I believe for Mac) to remove it, then click and release on the start point of a known distance (in your example the double doorway), click and release on the endpoint of your known distance , let go of the mouse, type 6’ and hit Return.

It is more complex to write than it is to do.

Answered here.

1 Like

Hey Box, I used the Option key to remove the little +/- in my Mac. Also, thank you very much for your reply. I could not have done it without your reply.

You say you do not understand why people get confused. I suspect it has something to do with the “click & release” you said twice. That changed everything for me.

Peter Enns