License page not loading in SketchUp, can't add license information

I just renewed my maintenance, license, support. When I download the trial version of 2015 and attempt to add my license, the text boxes are missing. See the attached screen shot. I am running Windows 8.1 on 64-bit machines. I tried this on 2 different computers, a desktop, and a Surface Pro 2. I am getting the same errors on both machines. Please advise.


I’ve got the same problem on my Mac version…

Help or advise welcome!


I found a solution, at least for me. Maybe it will work for everyone else. I had to manually go into the firewall settings and tell Windows Firewall (in my case Windows, I am not sure how to do it on a Mac) that Sketchup 2015 existed on the system by creating a new rule. I would have thought that the installer would have done this, it did for Sketchup 8, 2013, & 2014, but not for 2015… Then I needed to allow all connections for this new “sketchup 2015” rule. After I did that, it worked. It worked right away for the Surface Pro, I needed to restart my desktop computer before it would work on that machine. I hope this helps.

Having a similar problem here, with our SketchUp 2014 Pro on Mac. Need help ASAP as we are working on a deadline!

We apologize for any inconvenience and are looking into it!


Glad to hear this worked for you. Has this helped anyone else?


This issue was resolved here - Sketchup Pro 2015 won't let me add a license