Leave site


#1

When I rotate the view with the middle mouse button down and hold every so often I have a popup with question ‘do you want to leave site - your changes may not be saved’. I cancel and continue. If I have no changes made the sketchup just quietly exits without the popup.
This happens with firefox 62.0, chrome 69.0.3497.92 on windows 10 on two computers one with nvidia and one with radon cards. Looks like browser and graphic card independent.
How do I get rid of this annoying interruptions - on average every 5 min - yes I must have infinite patience :slight_smile:


#2

Is it possible you’re inadvertently moving the cursor over a shortcut tab just above the modeling window? Or possibly close the tab?

When it exits the SketchUp site, what is displayed?


#3

It is definitely a possibility - this type of consistent behavior across browsers and computers must be a ‘feature’. I have just narrowed it down to specific operation. I repeated the same operation leading to quiet exit: 1. press and hold middle button to rotate the model 2. move the mouse around to rotate the model around 3. release the button to stop rotating paying attention to have the mouse cursor in the middle of the model. 4. repeat the steps 1, 2, 3 some 5 to 10 times - the tab closes. I pay attention that I am in the middle of the window and releasing the mouse button causes it.


#4

I’ve tried to duplicate the behavior but haven’t been successful. Even after repeating the orbit operation considerably more than 10 times, I’m not having any issues with exiting or even the threat of exiting the session.

I don’t believe this is a “feature” of Sketchup Free.


#5

I think I found the cause - it is my usb mouse logitech m325 scrolling wheel that is a middle button as well. If you release it a little bit sideways, not straight up it closes the tab. It must be generating some strange combination of mouse events at that time. Changing the mouse now…


#6

Some mouse do have a wheel with a sideways function I think.


#7

You are right - that sideways on the wheel is doing browser back or forward. Now how do I disable that? I guess logitech forum now…


#8

If you’ve got the Logitech drivers installed you should be able to disable or at least assign something inocuous to the sideways action on the wheel. They are labeled Left Scroll and Right Scroll.


#9

Do you need that functionality somewhere else? Otherwise you can try to deinstall the Logitech driver…


#10

Problem fixed. Thanks DaveR, mics_54 and others! Installed logitech drivers and assigned ‘do nothing’ to the side wheel functions.