Layout scaling problems

I’m new to Sketchup, learning from video courses. Operating system Windows 10 Pro Russian, the latest version with all the latest updates. Faced such a problem, I can not solve it not clumsily. When scaling in Layout, let’s say a clipping mask, or any object, if you enter the size in millimeters (mm), then the millimeters entered in English letters mm are not perceived by the program at all and the element is scaled not by, say, 200mm, but 200 times. In Russian, the letters mm are not entered, I tried it in 2020, 2021 versions. I was able to treat this in only two ways, or change the Regional Standards to English (USA) and reboot, then the Layout interface becomes English, or rename the “C: \ Program Files \ SketchUp \ SketchUp 2020 \ LayOut \ en_US” folder to “ru”, and erase the original ru, while part of the Layout interface becomes in English. After that, scaling treats records like 200mm as “two hundred millimeters” rather than 200 times. I also tried to install pure Win10 on the virtual machine, install only Sketchup, in case my operating system is clumsy. But the scaling behavior is also not correct.
If anyone came across how to solve this problem? In order not to change the interface to English.

Hello Zpslon,

I believe the problem you are encountering is that the string parser is looking for the Russian мм characters instead of the English mm characters. When it doesn’t find what it is looking for, it decides that the input must be a multiplication factor instead of a size. Can you try using мм or ММ when inputting the size with your Russian build?

Sorry for the inconvenience,

Russian letters are not printed, only English input works. Even with russian interface. Much like a bug in a program

After deleting the file “C: \ Program Files \ SketchUp \ SketchUp 2020 \ LayOut \ ru \ LayOut.resources.dll” part of the Layout interface becomes in English and scaling works correctly. I did not find another method.