LAYOUT - MAC to PC Same File = SLOW

Hi all. I have recently changed back to PC Windows 10 after a few years on Mac. I have been working seamlessly in Layout and have been quite happy with it while on Mac.

Every time I open a document on my PC and every new document I create with Layout on Windows its SLOWWWWWW. Like so slow I just go back to using the Mac because I feel like throwing my super expensive PC out the window.

Could this be a setting, my driver, Mac files? PLEASE HELP. If I open the same files on my PC it’s almost unusable. It’s jarring and it takes 6 billion light-years to zoom in an inch. When I open the same document on my Mac it zooms instantly seamlessly. I can flick between pages and its not slow at all.

One thing - on my Mac I was using Icloud for backup. On my PC I’m using One Drive. Not sure if that’s relevant but all my work is stored in the cloud as well as locally.

Has anyone else had this issue?

Thanks in advance.

Jo

I switched from Mac to PC recently too…

If your working files (.skp/.layout) are in a OneDrive folder that could be part of the problem, OneDrive/SharePoint is a joke and really screwed up my work files. Also, just try to restart your PC, it might help (PCs need to be restarted more than Macs). But PCs are definitely clunkier than Macs. My 2014 MacBook Pro is smoother and easier than my very new higher-end gaming-spec PC. But of course, my PC can do things my Mac could only dream of, rendering-wise.

My advice for cloud storage is to use a backup service like BackBlaze and use One Drive for sharing a few files at a time. Also, Dropbox works pretty well. It works the way One Drive/SharePoint should work, but it might be more expensive. I used it at my last job and it was pretty convenient, but it did use up ridiculous amounts of network bandwidth.

1 Like

Hi Jo, would you be able to share an example file with me? Or if you could explain what the file consists of: A number of SketchUp models / Dimensioned / A lot of text… etc.

You could email me it at trent@sketchup.com and I will keep it private.

Thanks
Trent

You’re not entirely clear about where your local SKP files live.
It sounds like you’re keeping them in the local OneDrive folder.

Try keeping your model files in a sub-folder of your Documents.
When you’re finished working with a file, Save it, and then Copy it to the OneDrive folder.

Cloud storage services are a wonderful thing.
However, you’ll find plenty of topics in this forum where they cause problems.

Fonts can also be a problem. Do you have the same fonts installed in your PC that your had in your Mac? I also guess that there is something going on when SketchUp tries to locate and update your SketchUp and other file references, the file systems being quite different.

1 Like

OMG i never thought of this, you’re right the file file paths! I will check and get back to you! Thanks so much all for your help!

Hi Geo,
Would I need to upload the files as and when I work (sounds messy - we work on lots of files with lots of references and links, not to mention the autosave backup files it would be a full time job to keep this accurate to be honest).

Would you say that we need to just keep a folder not synced? Then upload at the end of the day? It would be all fo our current projects, so i feel it might be risky. Thank yo so much for your time helping with this!

Thank you for your item with this!
Honestly, now I have tried starting a few new files on the PC without the fonts and trying everything native and it hasn’t helped at all.

In fairness, our file sizes are quite large but it never seemed an issue on the Mac :frowning:

1] Turn off, disable, or uninstall OneDrive — Microsoft Support


2] Always save to your local drive.
That means never save your working file to any form of external or removable storage.

3] Only open and work with files from your local drive.
That means never open and work in a file that lives on any form of external or removable storage.

4] Copy your working files to any form of external or removable storage you please.

1 Like

It could likely be the machine itself. There’s a possibility the PC doesn’t have as powerful a CPU and/or GPU or RAM or HD speed. While it could be as simple as a setting, SketchUp does rely on pure processing power at the end of the day. What were your Mac’s specs, and what are the specs of your PC?

Thanks Monospaced - the pc is a Microsoft surface studio 2 TB intel core i7 solid state HD, 64GB ram. The mac was an old Imac Intel i5 32G 1600MHz DDr3 NVIDIA GeForce GT 755M 1GB (standard off the shelf - I thin kit was the cheapest one you could get about 7 years ago).

Thanks Geo, I will ask my Techie to do this! I’ll let you know how we go and if it makes a difference!

HI Trent, did you get my file? I sent it a while back?

Hi joski, I see it now. It was sent to my spam.

I will take a look now.
Trent