Layout keeps spinning my drawing when I select it - why?

Screenshot%20(123)

This seems to happen when I select my drawing in Layout. Layout really makes my not want to keep using SketchUP… I think that the developers have spent all their time improving SketchUp but forgot about Layout. It is a very slow tedious program with many glitches.

Looks like the screenshot didn’t capture the arrows but they are two curved arrows that look like they are spinning something… I don’t know where it comes from but I don’t want it and am simply trying to move my selection around not spin it.

Don’t click on the rotate handle when you want to move it.

I don’t know exactly the issue here, because

But the best advice I could give is to avoid entering into layout viewport,by create all layout view in the skecthup model ,you could avoid entering your layout viewport.

Second, as my colleague’s advice, is to separate all your layout page into single file. I don’t found it practical to be honest, but at least it could minimise your file size.

It’s hard to know what is happening without seeing a video, but it does seem likely that you have double clicked into a Layout window. One of the “flaws” of SU/LO is that it allows you to do things that are not good practice (like having raw geometry on anything other than Layer 0 in SU). In LO, you can manipulate what you see by “opening” the window but it is bad practice because it breaks the link to the SU drawing. You should really only be changing the views within SU and simply looking at what you’ve done in LO. Obviously, you can change things like scale and the size of the viewing “window”. People often describe a LO “window” as like having a cutout in a plane above the SU plane which you can move, resize, and move up and down, but that does not alter the model plane below.

Hi Daud, from what I can tell it looks like the SketchUp model viewport is being entered. The original Scene was oriented in one direction then the viewport was rotated in LayOut to align how you would like (this is totally fine). However in cases like this, if the SketchUp model viewport is accessed then you will see a ‘Rotate’ of the view.

It is best not to enter the SketchUp model view once you have the scale and rotation set as this should be established by the defined scene in SketchUp. Control of Scale can be accomplished by selecting the SketchUp model view and adjusting the scale via the SketchUp Model inspector. Additional viewport adjustments can be made by dragging the viewport edges.

Thanks for your concerns and we understand the performance issues within LayOut and are looking into ways to address them.

Trent

I know this is flogging a dead / dying horse, but I would like to be able to toggle off (at the Preferences or Document Setup level) the ability to open the SU model in the viewport. I occasionally need to unlock the LO layer(s) holding the viewports do something or other, and inadvertently open the model which then requires closing it and Undo clicking several times. This is particularly a problem with stacked viewports. Since there is for the most part no reason to open the model in the viewport, it would be desirable to toggle off that feature. This is a minor but persistent aggravation.

Agreed… You can lock viewports, though, and prevent inadvertently opening them.

Thank you for the helpful feedback.

Okay it seems I had a lot of different ideas given to me so I better respond with one message because I am still having the same problem and it is actually totally stopping me from doing very simple tasks to finish my drawing in Layout.

I have completed a drawing in SketchUp, I used parallel projection and saved the scene in top view (it is 2D). I then sent the drawing to Layout. In Layout I adjusted the scale to what I wanted but then when I try to move the selection around on the page to position it better, LO immediately brings up the Orbit tool and I cannot reposition my selection and make the blue box selection bigger to have it better fit on my page. So this seems like a pretty simple task to drag and resize but not so. I should also mention that Layout is very slow and takes forever to load up the blue selection box when I click on the drawing. I have no problem with Sketchup and find it enjoyable to draw in but it is very much the opposite for finalizing the drawing in Layout.

I am not sure if this has to do with viewports but I do not know what view ports are let alone how to use them. Turns out this last stage in Layout is the most time consuming even though you would think it should be easy to label your drawing and scale it etc.

I have attached my SketchUp drawing, there is no point in attaching the layout file as I have done barley anything in the program when I can’t event have the drawing positioned on the page how I need it to label it.

Also here is a screenshot which shows me in Layout with the drawing, trying to make the blue selection box bigger but everytime I click to resize it, the orbit tool pops up and won’t go away. :

Thanks

ThanksWindow Head and Sillskp.skp (203.9 KB)

You aren’t selecting the viewport. You are double clicking on it which opens the viewport and accesses the SketchUp camera tools. Simple fix: DO NOT double click on the viewport.

This is likely due to your computer. I have your file open in LO and don’t have any problems.

From the description of what you are doing, I think this can mostly be attributed to user error.

A viewport is the blue-framed window that shows your model. Again, it’s only time consuming because you aren’t using it correctly.

Again, don’t double click on the viewport. If you want to resize the viewport, drag its edges or corners.

Thank you Dave for the comprehensive reply. I am sure it will be helpful. I will give it another go but I do have to wonder why SketchUP runs fine on my computer without being slow meanwIhile Layout is a real nightmare. After many hours of fiddling with Layout, it is anything but intuitive.

I just wanted to report back that I am definitely not double clicking the object to have the blue selection box. Just a single click and the orbit tool flashes up, making it difficult to do a simple thing as moving my sketchup drawing over to have it where I want it on the page.

So when you single click on the viewport, it looks something liker this with the Orbit tool showing?

Yes it does

I’d be investigating the mouse, then. Apparently your single click is getting registered as a double click.