Layout bug - changing stroke colour

It might just be me but every time I want to change the stroke colour of something in Layout I always have to do it twice for it to actually change.

Here are the steps I take:

  1. Left click on the “stroke colour” box within the Shape Style menu.
  2. Scroll through colours in the colour menu and pick one
  3. Nothing changes
  4. Repeat steps 1 and 2 and colour then changes

Do you actually have something selected before you go to set the Stroke color? It may be that the Stroke color was already active and you deactivated it when you clicked on the button.

Stroke Color active:

Stroke color setting not active.

Share an example LO file where you have this problem.

1 Like

Thanks Dave, as I suspected it was a case of me not quite getting the required order of things right.

I think I thought that to change the colour of something I had to click on the swatch next to the Stroke buton in Shape Style and as a result was actually deactivating the stroke colour setting as per your screenshots! Now that I get the logic of how Layout wants it selected it works everytime!

You do have to do it once to let LO know you want to edit that color but once it’s activated, you don’t need to click it again. Keep in mind that if want to change the color of something else and click that color swatch button, say next to Fill or in Text style, you’ll make Stroke color swatch inactive. And of course in order for a change to actually be made you need to have an appropriate entity or tool selected.