LayOut Behavior

I’m an experienced SketchUp user trying to start learning LayOut. I’m seeing what I think is odd behavior when trying to use LayOut. I’m running Windows 10.

  1. If I open LayOut and try to load a SketchUp SKP file, I get an error that says "Error reading LayOut file - " followed by the path and filename.
  2. I think the taskbar icon is wrong. It looks like a sheet of paper in portrait mode with the upper-right corner dog-eared. It doesn’t look like the LayOut logo.
  3. If I come from SketchUp and use File > Send to LayOut …, LayOut opens with the correct image from SketchUp but the taskbar icon still looks wrong.

I’ve uninstalled and reinstalled SketchUp 2020.1 but there is no change in behavior.

What exactly are you doing to to “load” the SketchUp file? The right procedure in LayOut would be to use File>Insert and select the SketchUp model file.

That sounds like a Windows issue. When you installed SketchUp and LayOut did you right click on the installer and select Run as administrator?

See above.

Just on the task bar icon point, I have seen cases where you do an update, so everything is the same path, but the taskbar shortcut icon gets into a confused state. Could happen with any Windows application. While LayOut is closed, unpin the taskbar icon, then open LayOut by some other means, then pin it again.

Thanks for your response.
I was trying to use File > Open … I discovered, as you indicated, that I should have used File > Insert…
I am the administrator and always run as the administrator. But I followed your suggestion and did an uninstall followed by installing using Run as administrator. The results were the same: the SketchUp and Style Builder icons are correct, but not the LayOut icon.

The taskbar icon isn’t pinned. It’s on the taskbar only when LayOut is running. However, I went to the LayOut folder, right-clicked on LayOut.exe and clicked on Pin to Taskbar. The pinned icon is still wrong.

Thanks for doing that test. Can you show a screenshot of what it looks like? As you can imagine, it’s supposed to be like this.

icons

It’s the one on the right. image

I tried to do a Repair but I get this error message. Could this message be related to the icon problem?


This window precedes the above message:
image

I don’t think so. It could be one of the things covered in this old Microsoft answer:

https://answers.microsoft.com/en-us/windows/forum/all/desktop-and-taskbar-icons-show-up-as-a-generic/118fa756-4dac-49da-bab7-1ef01400c4cb

An uninstall and install/run as admin, ought to be the same as a repair, but would not rely on MSI files that are in a temp folder. That on its own seems odd, but I would just either do nothing, and try to fix the icon issue, or do another uninstall/reinstall.

I’ve edited and updated this response. On a hunch, I uninstalled SketchUp and installed this version: SketchUpPro-2020-1-229-63.exe. (It was the newest download I had before 2020.1). The icon for LayOut now looks right. I suspect there’s a flaw in the SketchUpPro-2020.1.1.exe download.

Whenever there are maintenance versions released I also get the problem with the pinned taskbar icons (blank taskbar icons or SU / LO icons that don’t map properly). I remove them and add them from fresh, that normally sorts it out.

How do you remove and add them?

That is the unpin, and pin I suggested, that you’ve already tried.