Layout 2019 on Mac Zooming

Hi all, this is definitely related to the iMacs. My office is running a majority of new iMacs with Layout. The latest update 2019.2 has not improved this. Could it be a retina issue?? This wouldn’t be the first time SU performance has been affected by Retina. I am running a MacBook Pro with no issues plugged into an older thunderbolt monitor, smooth zooming. My PC user also has no issue here regarding layout zoom. All our iMacs seem to be in the same boat. Please if you could fix this it would be HUGE.

1 Like

Any solution on the problem yet, I just updated to macOS Catalina 10.15.1 and also experiencing the problem.

Running on a new iMac (Retina 5K, 27-inch, 2019), 3.1 GHz 6-Core Intel Core i5, 8 GB 2667 MHz DDR4, Radeon Pro 575X 4 GB.

2 Likes

How can we escalate this problem?

This is unacceptable.

1 Like

I’m really hoping it is sorted soon.

Layout is absolutely frustrating to use on my iMac. It really affects my workflow and slows me down so much.

My older MacBook Pro runs fine and is so much smoother. Sketchup Pro on my iMac is smooth and fine too. I have 40GB RAM, 4GB GPU and an External 8GB GPU in a Razer Core X enclosure, which works wonderfully with Twinmotion.

The ONLY letdown is Layout.

I would be more than happy if Sketchup is only tweaked for the next Release, (sorting some of the minor Bugs etc), with ALL of the work being spent sorting out Layout.

I am a little cynical as to whether Layout will get sorted.

The other issue now, which has been going on for some time, is the strange lines which appear. This is a major headache as it means spending a considerable amount of time checking everytime to ensure that there are no odd lines anywhere, before PDF ing and sending to a Client.

An update on these Layout issues would be greatly appreciated.

Mike

1 Like

I agree with everyone. I would also like to see this fixed! These are the specs of my newer work computer:
39%20AM

Since I don’t have the option of using my older computer to just use Layout, I spent some time yesterday searching for ways to make this work for me. Either changing resolution or something else. I did find this temporary solution:

  1. Close all instances of Layout on your computer, then go to your Applications folder and navigate to Layout, right click “Get Info”

  2. Then, in the “Get Info” menu, click the checkbox next to “Open in Low Resolution”

I say this is a temporary solution because obviously the resolution is lower and Layout is a tiny bit blurry because of that BUT it makes zooming and panning less painful!

Dez

2 Likes

Hi Dez

Yes, it’s absolutely, alarmingly frustrating. I hope it gets sorted. Cynically, I don’t believe it will.

Temporary Solution sounds good though. I’ll try that. When you say slightly blurry, how bad is it?

Mike

Mike,

The edges of what I’m detailing has a slight blur around them. (I tired taking a screenshot but it doesn’t do it justice). It’s really not too terrible, I got used to it after a couple days. I would suggest you give it a try. You can always uncheck the “Open in Low Resolution” box if it really bothers you. I can confirm that when I print my drawing from Layout, it prints out normally (not blurry). So it all has to do with the resolution of the computer screen.

Good luck!

Dez

Hi Dez

Tried it on my MacBook Pro and it did speed it up slightly, so I’ll give it a try on my iMac.

Mike

Hi all, I finally find a solution for one of my Sketchup customer.

I change the my mac OS Preference / Display and change color to RVB. He tell me that it change the zoom reaction.

My current mac doesn’t have this trouble ( because the graphic card is not the same). If it dosen’t work please try other setup.

RGB

2 Likes

Thankyou @denis_bolomier

This has made a massive difference to the zoom on my iMac! No idea why but it has really sped up the rate at which Layout zooms.

I changed mine to Generic RGB.

I’m now thinking that is the reason my MacBook Pro had no problems, because it uses a Profile I created when I calibrated the screen, when I used to do Photography.

Mike

On my MacBook Pro using the Generic RGB does speed up zooming, but gives everything a darker look. Using the sRGB profile looked better, and still improved the zooming.

@trent Is there some science behind why the color profile affects LayOut’s zooming performance?

Judging from posts seen lately in this forum, colour profile also affects LayOut output, especially exports to PDF, in unpredictable ways.

Just wanted to add to this thread, @colin

I had a thought that maybe if I calibrate my Screen using my Spyder 5 Pro, creating a Profile, that this might help.

Calibration all good and Profile Created.

However, the Zooming in Layout returns to the same dead snail as with the Standard iMac Profile.

Looks like I’ll be using sRGB when using Layout. At least I now have a calibrated Screen, useful for any image and texture matching work anyway. I’ll just have to switch between the two.

Mike

Boy, does that seem nutty. Why is a good question.

I suspect the mac screens are now optimised for ‘metal’ and any app that alter or reset the colour profiles would need to take ‘metal’ into account…

john

Was showing someone the difference in zooming speed with the different profiles, and did a test when set to Vector. Zooming in vector was smoother with any profile than Raster its with the best profile.

That somehow makes sense to me, like macOS its having to work harder on altering the color profile of bitmaps, if only because it’s a lot more pixels to fix. As you can imagine, Hybrid its also slower.

Just wanted to mention it as an option to getting smoother zooming.

1 Like

My initial impression is that this is still a problem in 2020.

I opened a Version 19 file into Layout 2020, and the zooming was, if anything slightly worse.

I will update when I actually use 2020 Layout to create a file and not open a Version 2019 file.

Sketchup does seem smoother, but Layout still seems to be a problem.

Mike

1 Like

Mike, did you see this?

Might be interesting to try it. I know it’s a SketchUp test, not LayOut.

Might try that later.

Theres always been a difference in my Older MacBook Pro and new iMac, (iMac slower, ridiculous really as it is way more powerful than the MacBook Pro, which has an integrated GPU).

Trying to solve another problem now of sorting the Skalp License, as it’s just thrown me out and I can not use Skalp at all.

Mike

I’m sorry I can’t help with the Skalp license thing. Maybe @Guy will see this.