Layout 2018 can't export PDF error "There was a problem exporting to this file"

On the fresh install I did about a year ago after the first pdf fail everything was working well, until earlier this year with several updates, it is difficult to say exactly what triggers it but update log would help for the next time, to be honest I was not expecting it to trip up a second time with the same machine whereas the laptop remains (fingers crossed) fine with updates.

We updated to version 2019 a few weeks ago and Layout on one of our computers is not exporting PDFs.

Tried:
• Layout (ran as admin) [No Fix]
• SketchUp Install / Repair (ran as admin) [No Fix]
• Layout file opened on another computer [Worked]

SketchUp 2019 Checkup (Ran as Admin)
Capture

DxDiag.txt (110.3 KB)

Sorry to hear that @Ninjoe - Im afraid its a long standing issue with no known remedy at present! If you look further back up this thread, people have recommended a full, clean install of your system - while this has worked for some, the problem has reoccured for others after doing a full, clean install…

It appears to only affect a very small group of users and seems to be hard to replicate by Trimble as there is apparently no record made when the error occurs. We are all waiting, with baited breath for a solution…

The only time I see this message on Layout is if I have a pdf file open with the same name I am trying to export. I export PDF from Layout several times a week with no issue unless that same named PDF is open.

I’m afraid that’s not the issue here @Sonder

1 Like

No PDF exists to give a name / file open conflict…

Sounds odd for sure. I was just mentioning my only experience with that message. I export PDFs weekly without any issues.

It is an odd one - and very frustrating! Because it seems to only affect a small group of users and is not replicable by Trimble there is no solution. You will note above that @chaz_plan did a clean install which resolved the problem, only for it to reappear later…

Samyell is right, is only a small minority of us but when it happens (without warning) it locks you out on any Layout versions both past and future with the dreaded message… something went wrong… but no clue as to what the conflict is. See we have a new entry with same problem (Ninjoe). Its not the software download its a conflict somewhere. Sadly as well as being time consuming I have to swap between laptop and desktop to export pdf’s. @sonder it does not matter what you do have or do not have open or how many times you re-install various versions it is broken and only at the moment the only fix is a clean install of Win 10 on the affected machine, I have had the issue since late 2017. Cannot work out if it is Dell machine or Microsoft pdf interaction. Does anyone run a Mac/Apple with same problem or is it just in Microsoft computers?

Hi @TheGuz, have a Dell Precision 7510 at work and a MacBook Pro running Bootcamp at home - both with the issue.

I didn’t spot your post for some reason (sorry for delay in responding) but have just tried all the tips in the link you posted and sadly, none of them fix the issue.

Given that this has just started to affect @Ninjoe, there are 3 live cases (with active users on this forum) that Trimble can investigate (4 if you take into account that I have the issue on 2 separate computers). What info can we send you @TheGuz to move this along and try to find a solution. We have posted PC names, software lists (on each machine), dates of windows updates - is any of this any use to you. What else can we send to you to help you to help us?

1 Like

Hi @samyell, its good to know its not Microsoft only machines, I export many times daily so its really annoying jumping to a laptop just to export, I dont realy want to have rely on that as the main workhorse but maybe I just might have to ! ?:face_with_raised_eyebrow:

Well, its a Mac but its running bootcamp (so both machines I have run Windows)…

@samyell just for reference and you may also agree if a pdf is exported in Sketchup rather than Layout that will produce a pdf. Layout export always crashes out so its something in LO if that helps anyone …

Yes - SU PDF print it fine. Its related to EXPORT PDF rather than PRINT PDF in LO. :grinning:

@TheGuz - I just noticed that I get a print error when I try to Export PDF. See image below. Doest this shed any light?


1 Like

Also, this computer had more RAM added around the same time SU/LO was updated. Could that be a factor.

A serial port is a physical port that should have a device connected. Possibly do a repair of the Adobe app or investigate the preferences for it.

Thank you for the new info. We’re still looking into this. Had another user with Adobe Acrobat DC and they were having problems exporting to PDF. Seeing a “There was a problem exporting to this file.” error. He didn’t want to uninstall it, so we installed CutePDF Writer and selected Print to PDF via CutePDF and everything worked fine.

I’d also be curious if the issue has been encountered or solved with other applications.
I found a few ideas worth looking into:
“Failed to Export PDF” when you downsample large images while exporting to PDF (InDesign)
InDesign “Failed to Export PDF”
Messages - Export to PDF eo.pdf error (Windows)
Office 2010 Problems Saving as PDF
CorelDRAW Graphics Suite 2018 - Big PDF export problems
Troubleshoot printing, PDF export | InDesign
Word 2016 for Windows save as .pdf fails
AutoDesk Inventor Export PDF error
Rhino6 Unable to Print to PDF

I can do this with Acrobat without a problem but I have to fiddle around with the settings each time and dont have as many options as in EXPORT. What I can’t do is EXPORT TO PDF. How does one change the PDF authoring tool that Layout uses to Export, can it be done??