Layout 2018 can't export PDF error "There was a problem exporting to this file"

Greetings.

Here exporting a BLANK FILE WORKS.

Following someones suggestion on a logo that was bugging the file, I decided to check my file over here.
Posting the results in case it can lighten up someones mind.

This page on the left does not export. The page on the right works fine.

Here, the viewport from the bottom left is, somehow, the cause.
If there any tests I can perform in order to help coming up with a solution, you all can count on me. =)

Running Windows 10 Build 18362.
Using GeForce 1060GTX 6GB
SketchUp PRO 2019.2

Best regards!
Felipe

1 Like

No new information, just another person affected and looking for a fix, thanks!

The problem just popped up on a brand new W10 machine which I assume has all the latest updates. We have two seats, both on W7, that export fine. The new one won’t export any drawing to any folder, as reported by others here. Other programs on the new machine (Word, etc.) can export to PDF fine.

When you installed SketchUp and LayOut, did you right click on the installer and use Run as administrator?

Dave, our IT contractor set the computer up and installed SketchUp, so “hopefully” is the best answer I can give. But in any case, has that fixed this issue for anyone who has reported it? Maybe I missed something
in this very long thread. I definitely saw several posts stating specifically that it did not.

image001.jpg

I have seen some posts that indicate it did help. There are numerous threads in which users have reported issues with both SketchUp and LayOut where installing or repairing using Run as administrator while logged in as the normal user, not as System Admin, have fixed the problems. At the very least, it would be a good idea to make sure installation was done correctly.

Incident report:
Just made a Layout file that wouldn’t export to PDF. After some exploring, found a hidden/very small item that was causing the problem. After deleting it, Layout did export to PDF.
Problem is in Page 3 “Top” window.
Bad-File.layout (975.1 KB) Good-File.layout (974.8 KB)

2 Likes

@Ninjoe
Good Find!
Inside the bad layout file the offending item appears to have been a corrupted linear dimension with data like the following

<e:rectangleBase x="-nan(ind)" y="nan" width="nan" height="nan">
<e:affineTransform m11="-nan(ind)" m12="-nan(ind)" m21="nan" m22="nan" tx="-nan(ind)" ty="nan" />
<e:points2f>-nan(ind),nan,3.34375,0.7343749</e:points2f

-nan(ind) is an IEEE floating point representation with the meaning ‘a negative indefinite Not A Number’. I’m guessing that these values should be rational numbers

We can hope that the example you provided will help speed the resolution of a few similar problems.

I hope you might have figured out the problem since it’s been a long time for the issue, I don’t what the issue is, but there is a alternate solution available to make PDF, you can go to “Print tab - print as a file - choose the path - Print” you’ll get the PDF file.

Thank You.

Let me know in my mail id (adeshgupta1996@gmail.com) if it doesn’t help out.

I have had the problem for 19 months and have just given up on there being a solution. It seems that Trimble can’t replicate the problem and as a result its very hard to find a solution. The issue for me occurs eve with a blank file from a native LO template. I open a blank A3 or A4 template, go to export PDF and get the error - there is literally nothing in the file (no text boxes, dimensions, lines, views etc) other than what Trimble programmed it to have…

I do the same as @adeshgupta1996 and have just stopped using EXPORT PDF altogether and use PRINT > PRINT PDF instead now.

according to the properties of the used PDF library “pdflib.dll” from the SU program directory the library is made by the company ‘PDFlib GmbH’ from Germany.

The library of SUP 19.2 is of version 9.0.2.0 from December 2018 whereas the recent version is 9.2.0.0 from February 2019. Fortunately they do provide downloads of their latest version which seems to work without a demo watermark if used in conjunction with a valid license key provided from the calling application (i.e. SUP).

Downloading the ‘C, C++’ x64 package allows to extract the latest lib version from the sub-directory “\pdflib” to the SketchUp program directory (typically “C:\Program Files\SketchUp\SketchUp 2019\”). Do rename the original lib from “pdflib.dll” to e.g. “pdflib.org.dll” before doing this.

Thanks @SketchUp3D_de - I’ll try this when I get some time…

@chaz_plan - perhaps you can give it a go too as you and I have both had the same issue?

Hi Sam, seems like the issue is still with some of us, like you I gave up EXPORT PDF althogether and used PRINT > PRINT PDF but after a number of months have to say the export is not as good as the one built into layout so outputs are not as good, are yours better/same/worse than layout output pdf (when it worked of course!). Interesting post by @SketchUp3D regarding pdf properties…I applaud his research and knowledge on this, - sounds more like where we should be going but I think its more in something being overwritten or directed elsewhere that produces the issue. I can use exactly the same version and download on my laptop and pdf export within layout works fine.
Like your post from 2 days ago I cannot emphasise enough a simple blank document can give the same result so it is not the file you are using its in the program, and I have had it for 19 months or more and after upgrading Win 10 as well as other programs.
I will give the pdf upgrade a go when I have time like you, upgrading to 2019 sounds like the issue will continue too:frowning_face:

Cool! I have a model where I found out that the problem was in a dimension entity inside my sketchup model.
Deleting it solved the issue. How can I get access to these parameters on the entity so I can check if the problem was the same as @Ninjoe ? Meaning, an undefined value in the entity itself

Perhaps we can find a track to a solution in this direction.

Hello @sWilliams!
As asked, the file is in the link below! Can’t post it here. Seems to be too big.

At least in my computer, the bug happens. Deleting the lower left viewport (the one with the section cut) solves the issue. In fact, digging deeper, deleting some dimensions inside this viewport solves the problem. The dimensions are not visible in the view cause the section is on ortho mode on and it is perpendicular to the point of view. They are not hidden, just invisible due to the angle we are looking at them.

Don’t know if you need the skp file as well. Let me know if so.
Sorry for the
Glad to help.

Thanks,

Felipe

I just spent a month learning how to use SketchUp. On Saturday, I converted to the paid version of SketchUp Pro (and yes I did the admin repair) and I just received “There was a problem exporting to this file”. Not happy at all. I’m not ashamed to say I actually cried reading the above thread. How can there not be a fix for this!! I have been exporting my work at least 15 times over the last month without any problems. Last night I exported different pages without any problems. The scene that fails the export is heavy with dimensions. I am able to export the scene WITHOUT dimensions. I also exported this scene before with dimensions (I added toilets and sinks and more dimensions this go around) with the free version using the same template that is failing. I should note that the dimensions have been added inside Layout not SketchUp. Any ideas would be greatly appreciated. Thank you in advance.

@BeccaC If you’ll upload your layout file to a service like Dropbox and send me a link, I’ll check it for obvious problems.

1 Like

I would love to but I don’t know how to setup dropbox. Possible to email it to you?

Major kudos to sWilliams who solved my problem. He is a miracle worker. Culprit was a faulty linear dimension. He repaired my file and all is well with the world. Thanks again sWilliams.

1 Like

It would be nice to know how to determine which dimension is faulty!

@BeccaC I feel your frustration!!!

However, as @adeshgupta1996 pointed out just a few posts above yours, there is a work around. You can just use the FILE>PRINT>PRINT PDF instead of EXPORT to PDF. If you don’t have acrobat then you may need to install a different PDF writer, there are some mentioned in the thread above.

I’ve given up on there being a fix for this. Im one of the original posters and have been looking for a solution for nearly 2 years now (first had this issue in november 2017!) - which is ridiculous!

As @chaz_plan says, the PDF quality using PRINT PDF is not as good as EXPORT but after hours poured into this thread looking for a solution, I have just accepted the drop in quality / flexibility and have had to ignore my preference for using the EXPORT method. I just PRINT to PDF and save myself the bother of waiting for a solution. That said @SketchUp3D_de has recommended a possible solution but I haven’t had time to try it out yet - if anyone else has time to try it and update this thread that would be great.

The issue with dimensions that you seem to have is similar but not the same as mine - I can’t EXPORT any PDF’s, even from a totally blank file with nothing in it. Does it do the same for you?

Given my experience with this, I wouldn’t hold your breath waiting for a solution. Just get PRINT PDF working and save yourself some frustration.

Hope you are at least able to use the PRINT function…