Layout 2017 - Dimension when aligning is wrong




I’m now using Layout 2017 and have trouble with the dimension feature.
When I try to define the dimension between 2 points, which are not vertically or horizontally aligned, normally Layout would automatically adjust the dimension to show the correct vertical or horizontal distance.
Since I’m using 2017, Layout is always showing the diagonal (aligned) distance between both points.
I’ve made a small drawing to represent the issue.

  • The black horizontal dimension of 9.5mm is correct. The reference points are the center of both circles on the bottom.
  • The green aligned dimension of 11.0mm is correct. The reference points are the center of the top left and bottom right circle.
  • The red horizontal dimension of 11.0mm is wrong. The reference points are the same as for the green one, but the value should have been adjusted to the horizontal distance (9.5mm).

Did I miss some settings to get the same behaviour as in 2016 or is it a bug?

Thank you very much.

Regards, Eric


Upload the .skp file so we can see what is happening.



Thanks for trying to help me.
I’ve made a layout sample file of my issue.

The original .skp file is here.

Just for information: The file has been migrated from Sketchup 2016.

I also tried to generate a smaller file from scratch. That works perfectly.



Does this look reasonable?

There are several things that are contributing to the problem.

You have grid snapping turned on which you are fighting and making it difficult to hit the centers of the holes.
You’ve modified the scene which doesn’t help.

This is dimensioned in the SketchUp file.


Hi Dave Thanks for your help.
Your drawing dimensions are correct. But I still don’t really understand what is happening.
I paid attention to select the circle center, but I agree it is actually difficult to select it.

I’ve now tried to just select the plate borders to measure the width and I get the same effect. Layout just shows the initial value (absolute distance between both points), even showing the horizontal or vertical dimension lines.

Any idea, why even this simple dimension doesn’t work.


same problem here. I thougth it was “normal” for LAyout and that there would be some key to it for LAyout to adapt the measure but it seems not. So what? is it a bug? Il always had it. LAyout has never correctly measured distance between two points which are not aligned.



We have addressed this issue in LayOut 2019. Check out this post: