Issues with SketchUp Pro 2015 and Yosemite....WEIRD!


#1

I am a long time user of SketchUp Pro and I have noticed an issue that I have not been able to correct since it has come out.

The issue I am having is that if I have been working with SU for more than a half hour my Yosemite desktop gets all messed up. For instance, I have my dock set to auto-hide. After I have been working for a while I have to click on the area where the dock is to show me the dock. I also have to click on each expanding command or dialogue box. I am running a clean system that is well maintained and cannot for the life of me figure out what is going on. This is the only software I am having issues with.

Anyone have any ideas??? I am open to try anything…


#2

First thing to always check is Ruby extensions. Dock hiding is a weird thing to have change - I’d suspect keyboard shortcuts?


#3

Can you please describe for me in detail, how do I check Ruby Extensions???


#4

Check your installed extensions, disable all, restart. Preferences->Extensions uncheck all. There’s command line flag you can disable ruby, if you still aren’t sure.

Keyboard shortcuts, check System Preferences->Keyboard->Shortcuts. On Yosemite, Dock hiding is option-cmd-D.

-b


#5

That did not fix the issue…when I exit SU the dock is locked in the hidden position and I have to click on it for it to show up.

Still Frustrated…I do not get it…this has never happened before…


#6

cmd-opt-D unhides though, correct?


#7

After the lock happens after I have been working in SU, it does not allow me to unhide the dock. I have to do a restart to get functionality back.

Not sure what to do…I have never seen this in any form of SU. I am completely up to date on SU and Mac OS X updates…

Got any other ideas? I really did not want to wipe the system and reload it from scratch.


#8

I’m nowhere close to an expert, but I’d advise against wiping your system. I just did that with a Windows machine due to a problem with Sketchup. My PC is also very solid. The only problem was Sketchup. The whole thing was a pain and I ended up with the same problem I started with.


#9

I’m also on Yosemite and SU 2015 and have never seen this happen no matter how long SU has been running. So, the conclusion is that it is something specific to your system…but what?

I agree with @iamdegman that a system reinstall is the absolute last resort (or maybe the first resort of the incompetent :wink:)!

Had you installed any new plugins or extensions shortly before this started to happen? If so, try removing those. On the other hand, did you get fresh 2015-tested versions of all your plugins/extensions, or copy them from a prior version? Barry is right: plugins can have strange effects that you would have thought impossible.


#10

First, I’d go into System Preferences->Shortcuts, and assign Dock hide/show to some very uniquely weird key combination, and see if it goes away.

There’s some developer things you can do to see what’s going on. Check on your machine first if it has the command “opensnoop”, or just type “man opensnoop” for the manual/instructions to it, in Terminal. It’s built on top of DTrace. If it’s there, use it. If not, you can download developer tools ( > 1 GB Xcode download, so re-install might be easier), and if you do

sudo opensnoop -n SketchUp

and enter your password, then launch SketchUp, you’ll see every file that SketchUp touches. Somewhere, it’s gotta be touching your preferences for Dock, which would be weird and unique to you, because we’ve never seen it.