Issue starting SketchUp Make 2017 when on domain network


#1

Im using SketchUp Make 2017 on my work computer. When I use it at home on my private network the application works fine but when i try to start it in the office network i doesn´t work. The application starts and i can choose my template but when it starts the drawing window is all white and im not able to open my local projects i have saved on my computer. I work as a network technician and i have checked the central firewalls but i cannot find that there are any traffic being blocked.

If anyone has any suggestions I would be thankful.


#2

Are you using the same computer? To me, a blank screen usually denotes graphics card driver problems, not network-related.


#3

It is the same laptop computer that I use both at Home and in the Office. The differences are that at Home I connect to my Home network thru WiFi and at the Office I connect to a port-replicator using USB-C interface.


#4

Is the port replicator connected to an external monitor, and is your screenshot from that?

I have had display issues with these port replicators. Older ones do not support high-resolution screens. Check that it has not interfered with your colour settings. I had an old Lenovo port replicator that, when connected, switched my monitor to 16-bit colour. SketchUp requires full (32-bit) colour so something like that might be the issue. You can also test connecting your laptop to the network directly with the cable without the replicator.


#5

I have checked all my settings today and i also reinstalled my monitor drivers but no difference. I wasn´t all that easy to find if it was 16-bit or 32-bit in Win10 but when i check the adapter settings and choose to list all modes i only get 32-bit options.

All my displays are configured the same way.


#6

You have three monitors. I have also had trouble with that and a port replicator. What happens if you close your laptop lid?


#7

It is closed, i have three external monitors. Two are connected thru display port and one is connected thru HDMI.


#8

I suspect your problem comes from the Display link usb adapter, you’re effectively using a software graphics card to do the heavy lifting. This can be very hit and miss.
I had such a hub a while back and on one screen I could watch youtube no problem on the other it was just a black screen, sketchup worked but not always and often required tweaking.
I had so much trouble getting the hub to work with different devices and operating systems I eventually abandoned it, it’s now in a box in a cupboard somewhere. I found the display link software/ drivers so sensitive to change that they weren’t worth the bother.

Edit: One way to check would be, exchange one of the external displays for the laptop screen and see if it works there.


#9

I have done some testing now. First i tried to disconnect my external monitors one by one with no progress in the issue then i tried to open the lid on my computer and start the application on that screen. One of my external monitors are duplicating the screen (HDMI connected monitor) and then the application starts as it should and work on both the internal screen on the computer and on the external monitor.


#10

I have now tried to remove and reinstall my DisplayLink drivers but no progress, i have also tried to move both powersupply and network cable from the port replicator to try to minimize the traffic going over the USB-C connection but no progress with those activities either.


#11

Issue seems to be solved. I noticed that my graphic driver was about a year old and found out in a DisplayLink forum that after like Dec 2017 there was an update regarding graphic drivers supporting OpenGL to indirect displays so i found a driver for my graphicscard from 17th of August 2018 and installed it and it seems to work now.

I wan´t to thank both Anssi and Box for giving me support in this question.


#12

btw, SketchUp Make is for non-commercial purposes only. Using it for business is a violation of the license agreement and requires a SketchUp Pro license.


#13

Hi

Im aware of that, i use it for my own personal project, just using my work computer. Sometimes i use it during work hours but still for my personal projects.